Catch invalid vccorlib GetProcAddress calls when running on the desktop

RESOLVED FIXED in mozilla16

Status

()

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
mozilla16
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 641852 [details] [diff] [review]
patch

Ran into this today. We landed some code that made a winrt related call to an entry point in vccorlib110.dll. Since we load a dummy dll on the desktop the calls failed. The result was an immediate exit due to a missing procedure with little indication of what the cause was. This patch catches these and dumps information to build logs for easier diagnosis.
Attachment #641852 - Flags: review?(ehsan)

Updated

7 years ago
Attachment #641852 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/17a9890a351a
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
You need to log in before you can comment on or make changes to this bug.