Please Push Betafarm v1.2.2 Tag To Production

VERIFIED FIXED

Status

Infrastructure & Operations
WebOps: Other
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: bensternthal, Assigned: gozer)

Tracking

Details

(Reporter)

Description

6 years ago
Please push betafarm to production, we are working on fixing the CSP persona bug that came up yesterday.

* Note please update the code from the "v1.2.2" tag on github

Same as our stage request https://bugzilla.mozilla.org/show_bug.cgi?id=773668

Thanks!

Updated

6 years ago
Assignee: server-ops-webops → cturra
push to prod complete.

[root@genericadm.private.phx1 mozillalabs.com]# bash -x update 
+ CODE_DIR=/data/genericrhel6/src/mozillalabs.com/betafarm
+ VENDOR_DIR=/data/genericrhel6/src/mozillalabs.com/betafarm/vendor
+ update_code
++ tee /data/genericrhel6/src/mozillalabs.com/betafarm/media/update_info.txt
+ echo -e 'Updating code...'
Updating code...
+ cd /data/genericrhel6/src/mozillalabs.com/betafarm
+ git fetch
From https://github.com/mozilla/betafarm
   da3b0e4..af1f822  master     -> origin/master
 * [new tag]         v1.2.2     -> v1.2.2
+ git checkout v1.2.2
Previous HEAD position was da3b0e4... Exempt search view from CSP.
HEAD is now at af1f822... Fix mistake with CSP setting.
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
+ echo -e 'Updating vendor submodules...'
Updating vendor submodules...
+ git submodule update --init --recursive -q
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
+ echo -e syncdb
syncdb
+ python /data/genericrhel6/src/mozillalabs.com/betafarm/manage.py syncdb
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
+ echo -e migrate
migrate
+ python /data/genericrhel6/src/mozillalabs.com/betafarm/manage.py migrate
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
+ echo -e 'manage.py tasks...'
manage.py tasks...
+ python /data/genericrhel6/src/mozillalabs.com/betafarm/manage.py cron get_isotope
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
+ python /data/genericrhel6/src/mozillalabs.com/betafarm/manage.py compress_assets
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
+ echo -e 'Cleaning gitignore and pyc files...'
Cleaning gitignore and pyc files...
+ cd /data/genericrhel6/src/mozillalabs.com/betafarm
+ find . -type f -name .gitignore -or -name '*.pyc' -delete
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
+ echo -e 'Storing revision information...'
Storing revision information...
+ cd /data/genericrhel6/src/mozillalabs.com/betafarm
+ git rev-parse HEAD
+ checkretval
+ retval=0
+ [[ 0 -gt 0 ]]
++ date
+ touch /data/genericrhel6/src/mozillalabs.com/betafarm/wsgi/betafarm.wsgi
+ echo 'finished at Fri Jul 13 09:25:10 PDT 2012'
finished at Fri Jul 13 09:25:10 PDT 2012
+ echo -e 'Deploying code...'
Deploying code...
+ '[' xterm == dumb ']'
+ /data/genericrhel6/deploy mozillalabs.com
[2012-07-13 09:25:10] Running rsync_project
[2012-07-13 09:25:10] [localhost] running: /usr/bin/rsync -aq --include '.gitkeep' --exclude '.git*' --exclude '.hg*' --exclude '.svn*' --exclude 'CVS' --delete /data/genericrhel6/src/mozillalabs.com/ /data/genericrhel6/www/mozillalabs.com/
[2012-07-13 09:25:11] [localhost] finished: /usr/bin/rsync -aq --include '.gitkeep' --exclude '.git*' --exclude '.hg*' --exclude '.svn*' --exclude 'CVS' --delete /data/genericrhel6/src/mozillalabs.com/ /data/genericrhel6/www/mozillalabs.com/ (1.072s)
[2012-07-13 09:25:11] Finished rsync_project (1.073s)
[2012-07-13 09:25:11] Running commit_www
[2012-07-13 09:25:11] [localhost] running: cd /data/genericrhel6/www && /usr/bin/git add .; /usr/bin/git commit -a -m 'deploy ['mozillalabs.com']'
[2012-07-13 09:25:31] [localhost] finished: cd /data/genericrhel6/www && /usr/bin/git add .; /usr/bin/git commit -a -m 'deploy ['mozillalabs.com']' (19.931s)
[localhost] out: [master 05617c3] deploy [mozillalabs.com]
[localhost] out: 5 files changed, 65 insertions(+), 30 deletions(-)
[localhost] out: rewrite mozillalabs.com/betafarm/media/update_info.txt (78%)
[2012-07-13 09:25:31] Finished commit_www (19.931s)
[2012-07-13 09:25:31] Running push_www
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
Hmm I now get a security error when we go to the site, pinging pmac to take a look.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
:bensternthal as discussed, this cert warning is because the load balancer is not serving a cert for (www.)mozillalabs.com. i have been trying to track down a cert that might have been generated for this, but cannot find it in our infrastructure. maybe there was one created in labs?


$ openssl s_client -connect mozillalabs.com:443 -showcerts
CONNECTED(00000003)
depth=1 /C=US/O=GeoTrust, Inc./CN=GeoTrust SSL CA
verify error:num=20:unable to get local issuer certificate
verify return:0
---
Certificate chain
 0 s:/serialNumber=I1oZ-yurbFWiPu/xP8HIzW3f9mApQvMv/C=US/ST=California/L=Mountain View/O=Mozilla Corporation/OU=IT/CN=tbpl.mozilla.org
   i:/C=US/O=GeoTrust, Inc./CN=GeoTrust SSL CA
-----BEGIN CERTIFICATE-----
MIIEjTCCA3WgAwIBAgIDAQtvMA0GCSqGSIb3DQEBBQUAMEAxCzAJBgNVBAYTAlVT
MRcwFQYDVQQKEw5HZW9UcnVzdCwgSW5jLjEYMBYGA1UEAxMPR2VvVHJ1c3QgU1NM
IENBMB4XDTExMTEyNzE5MzIwMVoXDTEzMTEyOTIwMjYxN1owgasxKTAnBgNVBAUT
IEkxb1oteXVyYkZXaVB1L3hQOEhJelczZjltQXBRdk12MQswCQYDVQQGEwJVUzET
MBEGA1UECBMKQ2FsaWZvcm5pYTEWMBQGA1UEBxMNTW91bnRhaW4gVmlldzEcMBoG
A1UEChMTTW96aWxsYSBDb3Jwb3JhdGlvbjELMAkGA1UECxMCSVQxGTAXBgNVBAMT
EHRicGwubW96aWxsYS5vcmcwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIB
AQD1EWjHvwiTbOe7zYO6HQvbOgoklKoq0/Gup8pNDfjRzhsrS2bd7Q7JK/ykR3oj
vsmCk1d6Fi1KcOvltTiTXklT82GvDoOj1HEXDRfdrkYI7aLmg9C5wfW0CtMsZaVX
RIrhZ4cJSOuKAIUKhpyqRlt8aFL0ELMVyH/+gsSG8MYAIpDx14+9xYLUzRU8HHSp
RgD/KaqqWjp+efXNX98SI5hbIj7SegjhhFlCBhT080Ky6hBvYuqbUmbNAdxDZuzw
vqE4nudXUTB+t6o7IRssuoaCgJqnSsNjdkUGTOV3dSUUcx4MMwgC9f5P6+zuS1Ev
RsP5pMp+5qjN0hpl4tOByMHbAgMBAAGjggEiMIIBHjAfBgNVHSMEGDAWgBRCeVQb
Yc1VKz5j1TxIV/Wf+0XOSjAOBgNVHQ8BAf8EBAMCBLAwHQYDVR0lBBYwFAYIKwYB
BQUHAwEGCCsGAQUFBwMCMBsGA1UdEQQUMBKCEHRicGwubW96aWxsYS5vcmcwPQYD
VR0fBDYwNDAyoDCgLoYsaHR0cDovL2d0c3NsLWNybC5nZW90cnVzdC5jb20vY3Js
cy9ndHNzbC5jcmwwHQYDVR0OBBYEFKbFDR1q1E4ibLcl7O3rjbBWb4D8MAwGA1Ud
EwEB/wQCMAAwQwYIKwYBBQUHAQEENzA1MDMGCCsGAQUFBzAChidodHRwOi8vZ3Rz
c2wtYWlhLmdlb3RydXN0LmNvbS9ndHNzbC5jcnQwDQYJKoZIhvcNAQEFBQADggEB
ADSATCNej/XT7BLpigMtj35rkkoG6dL4YLfju3QXfpBbUQUO8bw26EQLDFgvMAJ2
sAbmwC/BI/3+hY15VBLc7duGLTfEqKBwiCK8z/1LK+rJTTW6Nk6g41SOYCptzOHN
mfpq/E6TrOmX4AzWcRNWF/rtwpE5SPEHd2qCFet4wraLZnipaGTaZipBRVzvPH/0
y5yp6U4TiEVQ23sVI6gOkmEgAm+fp4zzvLWOR5ytFbjv8tL0UgDgXBX6kbZirwJH
Cfx2m6O2lRTp56YYWXSC1vKV5SpbSlU+q3nRFEB5+3CdKdl6ZN+nt7YQI/YiEL9Z
Qub72UAbyDS7mFRxCmK3nyY=
-----END CERTIFICATE-----
 1 s:/C=US/O=GeoTrust, Inc./CN=GeoTrust SSL CA
   i:/C=US/O=GeoTrust Inc./CN=GeoTrust Global CA
-----BEGIN CERTIFICATE-----
MIID2TCCAsGgAwIBAgIDAjbQMA0GCSqGSIb3DQEBBQUAMEIxCzAJBgNVBAYTAlVT
MRYwFAYDVQQKEw1HZW9UcnVzdCBJbmMuMRswGQYDVQQDExJHZW9UcnVzdCBHbG9i
YWwgQ0EwHhcNMTAwMjE5MjIzOTI2WhcNMjAwMjE4MjIzOTI2WjBAMQswCQYDVQQG
EwJVUzEXMBUGA1UEChMOR2VvVHJ1c3QsIEluYy4xGDAWBgNVBAMTD0dlb1RydXN0
IFNTTCBDQTCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBAJCzgMHk5Uat
cGA9uuUU3Z6KXot1WubKbUGlI+g5hSZ6p1V3mkihkn46HhrxJ6ujTDnMyz1Hr4Gu
FmpcN+9FQf37mpc8oEOdxt8XIdGKolbCA0mEEoE+yQpUYGa5jFTk+eb5lPHgX3UR
8im55IaisYmtph6DKWOy8FQchQt65+EuDa+kvc3nsVrXjAVaDktzKIt1XTTYdwvh
dGLicTBi2LyKBeUxY0pUiWozeKdOVSQdl+8a5BLGDzAYtDRN4dgjOyFbLTAZJQ50
96QhS6CkIMlszZhWwPKoXz4mdaAN+DaIiixafWcwqQ/RmXAueOFRJq9VeiS+jDkN
d53eAsMMvR8CAwEAAaOB2TCB1jAOBgNVHQ8BAf8EBAMCAQYwHQYDVR0OBBYEFEJ5
VBthzVUrPmPVPEhX9Z/7Rc5KMB8GA1UdIwQYMBaAFMB6mGiNifurBWQMEX2qfWW4
ysxOMBIGA1UdEwEB/wQIMAYBAf8CAQAwOgYDVR0fBDMwMTAvoC2gK4YpaHR0cDov
L2NybC5nZW90cnVzdC5jb20vY3Jscy9ndGdsb2JhbC5jcmwwNAYIKwYBBQUHAQEE
KDAmMCQGCCsGAQUFBzABhhhodHRwOi8vb2NzcC5nZW90cnVzdC5jb20wDQYJKoZI
hvcNAQEFBQADggEBANTvU4ToGr2hiwTAqfVfoRB4RV2yV2pOJMtlTjGXkZrUJPji
J2ZwMZzBYlQG55cdOprApClICq8kx6jEmlTBfEx4TCtoLF0XplR4TEbigMMfOHES
0tdT41SFULgCy+5jOvhWiU1Vuy7AyBh3hjELC3DwfjWDpCoTZFZnNF0WX3OsewYk
2k9QbSqr0E1TQcKOu3EDSSmGGM8hQkx0YlEVxW+o78Qn5Rsz3VqI138S0adhJR/V
4NwdzxoQ2KDLX4z6DOW/cf/lXUQdpj6HR/oaToODEj+IZpWYeZqF6wJHzSXj8gYE
TpnKXKBuervdo5AaRTPvvz7SBMS24CqFZUE+ENQ=
-----END CERTIFICATE-----
---
Server certificate
subject=/serialNumber=I1oZ-yurbFWiPu/xP8HIzW3f9mApQvMv/C=US/ST=California/L=Mountain View/O=Mozilla Corporation/OU=IT/CN=tbpl.mozilla.org
issuer=/C=US/O=GeoTrust, Inc./CN=GeoTrust SSL CA
---
No client certificate CA names sent
---
SSL handshake has read 2318 bytes and written 444 bytes
---
New, TLSv1/SSLv3, Cipher is RC4-SHA
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
SSL-Session:
    Protocol  : TLSv1
    Cipher    : RC4-SHA
    Session-ID: 894FC8D87190DDEA83197178129BA3AB74678E4D1657F23C259665ED77AB59AF
    Session-ID-ctx: 
    Master-Key: DC2C18E72A0E481E3254B8A9E6E24AD5D599F7522619E7DDB243C3156032F22CD2EFC6413B512FC366BBF67E89EA3F69
    Key-Arg   : None
    Start Time: 1342197989
    Timeout   : 300 (sec)
    Verify return code: 0 (ok)
(Reporter)

Updated

6 years ago
Depends on: 773694
(Reporter)

Comment 4

6 years ago
Gozer, can you see if we have a cert already for mozillalabs? If not cturra will go ahead and set this up.
Assignee: cturra → gozer
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

6 years ago
(In reply to Ben (:bensternthal) from comment #4)
> Gozer, can you see if we have a cert already for mozillalabs? If not cturra
> will go ahead and set this up.

Yes, there is a cert for mozillalabs.com used by the Zeus cluster in labs. It can be shared, I imagine.
cert issue fixed in bug 773694 and the following redirect applied to all prod web heads...

  RewriteCond %{HTTP_HOST} ^.*\.mozillalabs\.com$ [NC]
  RewriteRule ^(.*)$ https://mozillalabs.com/$1   [L,R=301]
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

6 years ago
Confirmed the following on (firefox/chrome):

- no longer receive cert error on www url 
- site redirects from www to non www url
- no longer get error on www url, resolved by redirect

Everything looks OK.
Status: RESOLVED → VERIFIED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.