Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Jonny, Unassigned)

Tracking

13 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

I use prefixfree.js as a browser fallback for css3 selectors. The latest release of firefox disables some CSS3 properties such as box-shadows. I have a working example here: http://www.fallingupmedia.com/clients/champion/index.php. You will see the box-shadows on some elements, then they disappear. All prefix free does is make it so someone doesnt have to type -moz- or -webkit- prefixes on css3 selectors, and I know this worked on all other versions of firefox. Why would this be conflicting now? I can disable prefixfree.js and type in the moz selectors, but then I have to do it for all other css3 selectors for other browsers, even though the javascript is working correctly for those browsers. Please - any help (other than saying to go talk to the developers of prefixfree, because it works with all other browsers) would be greatly appreciated.


Actual results:

Box shadows and other css3 selections being disabled


Expected results:

This works on all other browsers and previous versions of Firefox.
(Reporter)

Comment 1

6 years ago
Also, if prefix free is enabled, even if you type in -moz- prefix on the selector, it will still disable the effect. This is significantly affecting designs.

Comment 2

6 years ago
As of Firefox 13, -moz- prefix is no longer supported on box-shadow and border-radius. Unless the unprefixed version is also used, the effect won't be applied.

https://developer.mozilla.org/en/Firefox_13_for_developers

"Support for -moz-border-radius* and -moz-box-shadow has been removed. Authors should use unprefixed border-radius or box-shadow instead. See bug 693510"
(Reporter)

Comment 3

6 years ago
Ah. See I put it in with out the -moz- normally when using prefixfree since prefixfree detects your browser and adds them for you. I will have to notify that team.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.