crash in RtlAllocateHeap (Bkav Firewall engine 3.0.0.38)

RESOLVED DUPLICATE of bug 773173

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED DUPLICATE of bug 773173
6 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, qawanted})

unspecified
x86
Windows NT
crash, qawanted
Points:
---

Firefox Tracking Flags

(firefox14-)

Details

(Whiteboard: [startupcrash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-a07c2f2e-f021-4963-94a3-dfa702120712 .
============================================================= 

Seen while looking at the explosive report. Affects beta as well as other versions.
100% Correlation to BkavFirewallEngine.dll - Version 100% (11/11) vs.   0% (161/74228) 3.0.0.38. 

https://crash-stats.mozilla.com/report/list?signature=RtlAllocateHeap%20|%20RtlpDosPathNameToRelativeNtPathName_Ustr%20|%20RtlDosPathNameToRelativeNtPathName_Ustr%20|%20RtlDoesFileExists_UstrEx%20|%20RtlDoesFileExists_UEx%20|%20NtdllDispatchHook_W



Frame 	Module 	Signature 	Source
0 	ntdll.dll 	RtlAllocateHeap 	
1 	ntdll.dll 	RtlpDosPathNameToRelativeNtPathName_Ustr 	
2 	ntdll.dll 	RtlDosPathNameToRelativeNtPathName_Ustr 	
3 	ntdll.dll 	RtlDoesFileExists_UstrEx 	
4 	ntdll.dll 	RtlDoesFileExists_UEx 	
5 	ntdll.dll 	NtdllDispatchHook_W 	
6 	KERNELBASE.dll 	SearchPathW 	
7 	xul.dll 	`anonymous namespace'::getFullPath 	toolkit/xre/nsWindowsDllBlocklist.cpp:304
8 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:460
9 	KERNELBASE.dll 	LoadLibraryExW 	
10 	kernel32.dll 	LoadLibraryW 	
11 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
12 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
13 		@0x1d3853 	
14 	KERNELBASE.dll 	BaseBeginReadingCache 	
15 	KERNELBASE.dll 	BemFreeContract 	
16 	ntdll.dll 	RtlpGetLFHContext 	
17 	KERNELBASE.dll 	BasepGetCachedPath 	
18 	ntdll.dll 	RtlpGetLFHContext 	
19 	KERNELBASE.dll 	BaseGetProcessDllPath 	
20 	KERNELBASE.dll 	BemFreeContract 	
21 	KERNELBASE.dll 	BasepComputeProcessExePath 	
22 	KERNELBASE.dll 	LoadLibraryExW 	
23 	mozalloc.dll 	mozalloc.dll@0x10af 	
24 		@0x1d38ef 	
25 	kernel32.dll 	LoadLibraryW 	
26 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
27 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
28 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367 	
29 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4504 	
30 	xul.dll 	`anonymous namespace'::CheckASLR 	toolkit/xre/nsWindowsDllBlocklist.cpp:211
31 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
32 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
33 	ntdll.dll 	RtlpGetLFHContext 	
34 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
35 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4242
36 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
37 	kernel32.dll 	LoadLibraryW 	
38 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
39 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
40 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367 	
41 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4504 	
42 	xul.dll 	`anonymous namespace'::CheckASLR 	toolkit/xre/nsWindowsDllBlocklist.cpp:211
43 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
44 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
45 	ntdll.dll 	RtlpGetLFHContext 	
46 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
47 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4242
48 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
49 	kernel32.dll 	LoadLibraryW 	
50 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
51 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
52 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367 	
53 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4504 	
54 	xul.dll 	`anonymous namespace'::CheckASLR 	toolkit/xre/nsWindowsDllBlocklist.cpp:211
55 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
56 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
57 	ntdll.dll 	RtlpGetLFHContext 	
58 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
59 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4242
60 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
61 	kernel32.dll 	LoadLibraryW 	
62 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
63 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
64 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367 	
65 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4504 	
66 	xul.dll 	`anonymous namespace'::CheckASLR 	toolkit/xre/nsWindowsDllBlocklist.cpp:211
67 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
68 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
69 	ntdll.dll 	RtlpGetLFHContext 	
70 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
71 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4242
72 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
73 	kernel32.dll 	LoadLibraryW 	
74 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
75 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
76 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367 	
77 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4504 	
78 	xul.dll 	`anonymous namespace'::CheckASLR 	toolkit/xre/nsWindowsDllBlocklist.cpp:211
79 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
80 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
81 	ntdll.dll 	RtlpGetLFHContext 	
82 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
83 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4242
84 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
85 	kernel32.dll 	LoadLibraryW 	
86 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
87 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
88 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367 	
89 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4504 	
90 	xul.dll 	`anonymous namespace'::CheckASLR 	toolkit/xre/nsWindowsDllBlocklist.cpp:211
91 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
92 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
93 	ntdll.dll 	RtlpGetLFHContext 	
94 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
95 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4242
96 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
97 	kernel32.dll 	LoadLibraryW 	
98 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
99 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
100 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367 	
1015 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
1016 	xul.dll 	`anonymous namespace'::patched_LdrLoadDll 	toolkit/xre/nsWindowsDllBlocklist.cpp:467
1017 	ntdll.dll 	RtlpGetLFHContext 	
1018 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
1019 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4242
1020 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
1021 	kernel32.dll 	LoadLibraryW 	
1022 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0xfed3 	
1023 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x38dab 	
1024 	BkavFirewallEngine.dll 	BkavFirewallEngine.dll@0x4367
(Reporter)

Updated

6 years ago
Crash Signature: [@ RtlAllocateHeap | RtlpDosPathNameToRelativeNtPathName_Ustr | RtlDosPathNameToRelativeNtPathName_Ustr | RtlDoesFileExists_UstrEx | RtlDoesFileExists_UEx | NtdllDispatchHook_W] → [@ RtlAllocateHeap | RtlpDosPathNameToRelativeNtPathName_Ustr | RtlDosPathNameToRelativeNtPathName_Ustr | RtlDoesFileExists_UstrEx | RtlDoesFileExists_UEx | NtdllDispatchHook_W] [@ RtlpDosPathNameToRelativeNtPathName_Ustr | RtlDosPathNameToRelativ…

Comment 1

6 years ago
Although this is affecting multiple versions, tracking for FF14 since we may need to take action before our final release build. Startup crashes highly correlated to a dll can only be blocked as part of our release build, not remotely.
tracking-firefox14: --- → +
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 773173
(Reporter)

Updated

6 years ago
tracking-firefox14: + → ---

Updated

6 years ago
tracking-firefox14: --- → -
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.