html5test.com crashes 15 Aurora

RESOLVED DUPLICATE of bug 750198

Status

()

--
critical
RESOLVED DUPLICATE of bug 750198
7 years ago
2 years ago

People

(Reporter: jfu, Unassigned)

Tracking

({crash})

15 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], crash signature, URL)

(Reporter)

Description

7 years ago
1. Open Firefox Aurora (15) on HTC Incredible 2
2. Type in html5test.com
3. Firefox crashes and I restart
4. Go to html5test.com again (it's registered in my Awesome Screen now)
5. Crashes again
(Reporter)

Comment 1

7 years ago
Just tried it on GA and it crashed too
Report submitted? Crash-id from about:crashes?

Updated

7 years ago
Severity: normal → critical
Keywords: crash
OS: Mac OS X → Android
Hardware: x86 → ARM
Whiteboard: [native-crash]

Updated

7 years ago
Keywords: stackwanted
Jaclyn, type about:crashes and provide the matching crash ID.
Crashing Thread
Frame 	Module 	Signature 	Source
0 	libc.so 	libc.so@0x165c0 	
1 	libEGL.so 	eglGetProcAddress 	
2 	libutils.so 	_ZN7android10VectorImpl7_shrinkEjj 	
3 		@0xafd476ba 	
4 	libc.so 	libc.so@0x13f03 	
5 	libc.so 	libc.so@0x14df3 	
6 	libstdc++.so 	_ZdlPv 	
7 	libEGL.so 	_ZN7android33egl_get_image_for_current_contextEPv 	
8 	libEGL.so 	eglDestroyContext 	
9 	libEGL.so 	eglMakeCurrent 	
10 	libxul.so 	mozilla::gl::GLContextEGL::MakeCurrentImpl 	gfx/gl/GLLibraryEGL.h:148
11 	libxul.so 	mozilla::gl::GLContext::MakeCurrent 	GLContext.h:618
12 	libxul.so 	mozilla::gl::GLContextEGL::Init 	gfx/gl/GLContextProviderEGL.cpp:330
13 	libxul.so 	mozilla::gl::GLContextEGL::CreateEGLPBufferOffscreenContext 	gfx/gl/GLContextProviderEGL.cpp:1739
14 	libxul.so 	mozilla::gl::GLContextProviderEGL::CreateOffscreen 	gfx/gl/GLContextProviderEGL.cpp:1919
15 	libxul.so 	mozilla::WebGLContext::SetDimensions 	content/canvas/src/WebGLContext.cpp:525
16 	libxul.so 	nsHTMLCanvasElement::UpdateContext 	content/html/content/src/nsHTMLCanvasElement.cpp:652
17 	libxul.so 	nsHTMLCanvasElement::GetContext 	content/html/content/src/nsHTMLCanvasElement.cpp:573
18 	libxul.so 	nsIDOMHTMLCanvasElement_GetContext 	obj-firefox/js/xpconnect/src/dom_quickstubs.cpp:17862
19 	libxul.so 	js::Interpret 	js/src/jscntxtinlines.h:314
20 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:475
21 	libxul.so 	js::Execute 	js/src/jsinterp.cpp:674
22 	libxul.so 	JS_EvaluateUCScriptForPrincipalsVersionOrigin 	js/src/jsapi.cpp:5304
23 	libxul.so 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1458
24 	libxul.so 	nsScriptLoader::EvaluateScript 	content/base/src/nsScriptLoader.cpp:918
25 	libxul.so 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:811
26 	libxul.so 	nsScriptLoader::ProcessScriptElement 	content/base/src/nsScriptLoader.cpp:757
27 	libxul.so 	nsScriptElement::MaybeProcessScript 	content/base/src/nsScriptElement.cpp:169
28 	libxul.so 	nsIScriptElement::AttemptToExecute 	nsIScriptElement.h:253
29 	libxul.so 	nsHtml5TreeOpExecutor::RunScript 	parser/html/nsHtml5TreeOpExecutor.cpp:779
30 	libxul.so 	nsHtml5TreeOpExecutor::RunFlushLoop 	parser/html/nsHtml5TreeOpExecutor.cpp:583
31 	libxul.so 	nsHtml5ExecutorReflusher::Run 	parser/html/nsHtml5TreeOpExecutor.cpp:97
32 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:656
33 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
34 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:114
35 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
36 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
37 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
38 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:295
39 	libxul.so 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3780
40 	libxul.so 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3857
41 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3933
42 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:109
43 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	mozglue/android/APKOpen.cpp:1002
44 	libdvm.so 	dvmPlatformInvoke 	
45 	libdvm.so 	dvmCallJNIMethod_general 	
46 	libdvm.so 	dvmResolveNativeMethod 	
47 	libdvm.so 	dvmAsmSisterStart 	
48 	libdvm.so 	dvmMterpStd 	
49 	libdvm.so 	dvmInterpret 	
50 	libdvm.so 	dvmCallMethodV 	
51 	libdvm.so 	dvmCallMethod 	
52 	libdvm.so 	dvmDetachCurrentThread 	
53 	libc.so 	libc.so@0x121da 	
54 	libc.so 	libc.so@0x11d9e
Crash Signature: [@ eglGetProcAddress ]

Updated

7 years ago
Component: General → Graphics, Panning and Zooming
Keywords: stackwanted
Version: unspecified → Firefox 15
This stack is very similar to bug 750198
tracking-fennec: --- → ?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750198
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.