Last Comment Bug 773888 - DEBUGLOG is extremely expensive
: DEBUGLOG is extremely expensive
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 17:48 PDT by :Ehsan Akhgari
Modified: 2012-07-13 18:17 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description :Ehsan Akhgari 2012-07-13 17:48:58 PDT
I just caught the Profiler add-on in my profile, and DEBUGLOG seems to be taking 30% of the total time.  Can we remove it from non-debug versions of the add-on?
Comment 1 :Ehsan Akhgari 2012-07-13 17:55:43 PDT
(In reply to comment #0)
> I just caught the Profiler add-on in my profile, and DEBUGLOG seems to be
> taking 30% of the total time.  Can we remove it from non-debug versions of the
> add-on?

That 30% mapped to around 300-400ms IIRC.
Comment 2 Benoit Girard (:BenWa) 2012-07-13 18:17:49 PDT
1.8.4 deployed

Note You need to log in before you can comment on or make changes to this bug.