Closed Bug 773915 Opened 7 years ago Closed 7 years ago

Firebot only responds to "koalabot" at the moment.

Categories

(Webtools Graveyard :: Mozbot, defect)

x86_64
Windows 8
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: KWierso, Unassigned)

Details

Trying to get a UUID from firebot in #developers tonight, ewong posted "firebot uuid", but there was no response.

When I tried "/msg firebot uuid", firebot responded with a UUID in a private message, though the message also included "(/msg koalabot cid for CID form)". Which was weird, since firebot's name at the moment is "firebot", not "koalabot".

When I went back to #developers and said "koalabot uuid", firebot responded back with a UUID.


Looks like a configuration change from a development instance carried over to whatever's running on moznet?
[22:43] <dolske> dolske: uuid
[22:43] <firebot> 31661200-1c5e-4f5c-9892-743293a44453 (/msg dolske cid for CID form)
...
[22:45] <KWierso> dolske: bug 773915
[22:45] <firebot> Bug https://bugzilla.mozilla.org/show_bug.cgi?id=773915 nor, --, ---, nobody, NEW, Firebot only responds to "koalabot" at the moment.

halp
The cause of firebot thinking it is dolske:

10:39 36	*** dolske is now known as koalabot
10:39 43	<koalabot>: koalabot: ping
10:39 44	<firebot>: koalabot: pong
10:39 48	*** koalabot is now known as dolske
10:40 00	<dolske>: disappointing.
10:40 10	<Havvy>: dolske: Should probably move to #foxymonkies
10:40 17	<firebot>: Havvy: Sorry, I've no idea what 'Should probably move to #foxymonkies' might be.
This was apparently fixed (for now, at least) by Reed kicking dolske out of the channel and changing firebot's nick to "dolske" and then back to "firebot".

I guess this could come up again in the future if firebot's ever listening to a nick other than its own, then someone changes their nick to whatever firebot is listening to, then changing their nick to something else?
(6:16:51 AM) Wolf: vars Admin nicks
(6:16:53 AM) firebot: Variable 'nicks' in module 'Admin' is a list with the following values: 'koalabot', 'firebot', 'firewolfbot', 'firebot2', 'notfirebot', 'dolske', 'IRCMonkey35175'
(6:16:57 AM) Wolf: vars Admin currentnick
(6:16:58 AM) firebot: Variable 'currentnick' in module 'Admin' is set to: 'firebot'

So, I assume most likely the uuid issue was somewhat caused by firebot not being the first nick in the list, not sure why (usually the primary name is)

I am definitely confused by how the additional nicks (dolske and IRCMonkey35175) got into that list. I suspect OnNickChanged handler to be at fault here though - especially if it thought its own nick had been administratively changed instead of just following along..

I'll remove the erroneous nicks and fix the sort order - hopefully that will sort things out in a runtime way, until I can figure out how this occured.
"dolske" got in the list because firebot thought its nick was "koalabot" and then saw "koalabot is now known as dolske" (comment 2).

So the question is how it came to think its nick was "koalabot" while its nick was actually "firebot".
(In reply to Jesse Ruderman from comment #5)
> "dolske" got in the list because firebot thought its nick was "koalabot" and
> then saw "koalabot is now known as dolske" (comment 2).
Yeah, so I figured when seeing Comment 2. I'm curious who IRCMonkey35175 was though. I don't have access to logs to trace it.

> 
> So the question is how it came to think its nick was "koalabot" while its
> nick was actually "firebot".

My only thought there, is that somewhere there's code that's making it use the first nick in the nicks array (so at runtime it thinks currentnick = 0 (koalabot) when it was 1 (firebot). Something that's not usually the case as firebot was first until recently.
IRCMonkey35175 was also dolske.
OK. That makes sense, it was following along with the changes to the most logical, if absurd, conclusion.
Seems this is fixed again
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Wolf: Before this is kept as WORKSFORME, is there anything we need to patch in the mozbot/firebot code base to prevent this in future?
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.