The default bug view has changed. See this FAQ.

Youtube HTML5 resize buttons(Small/Large player) in video controls are missing

VERIFIED FIXED in Firefox 16

Status

()

Core
JavaScript Engine
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: luke)

Tracking

({regression})

16 Branch
mozilla17
x86_64
All
regression
Points:
---

Firefox Tracking Flags

(firefox16+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/131961e5e0d1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120612030527

this is regression of Bug 765956

Steps to Reproduce:
1. Create clean profile
2. Open http://www.youtube.com/watch?v=BRG5VNNUq_E&hd=1&html5=1

Actual Results:
 Resize buttons(Small/Large player) are missing.


m-i hourly build:
last good is mozilla-inbound changeset e3c30588f319
first bad is mozilla-inbound changeset 67e09e165ce6

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e3c30588f319&tochange=67e09e165ce6

In local build 
Last Good: 749d103d8636	
First Bad: d9650bc4da1a
(Reporter)

Updated

5 years ago
tracking-firefox16: --- → ?
(Reporter)

Comment 1

5 years ago
Err
Correct Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/6489be1890c0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120713030548

And also reproduced in latest hourly
http://hg.mozilla.org/mozilla-central/rev/0602e44ac248
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120713204920
(Reporter)

Updated

5 years ago
Depends on: 774169
(Reporter)

Updated

5 years ago
No longer depends on: 774169
(Assignee)

Comment 2

5 years ago
Created attachment 642737 [details] [diff] [review]
fix

The problem is that bug 765956 removed an "|| fun->script->isInnerFunction" guard in CheckNewScriptProperties.  Why this matters isn't clear and I filed bug 774463 to investigate.  In the meantime, the quick fix is to restore the old behavior by disallowing CheckNewScriptProperties on inner functions.
Assignee: general → luke
Status: NEW → ASSIGNED
Attachment #642737 - Flags: review?(bhackett1024)
Attachment #642737 - Flags: review?(bhackett1024) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a3441f550c0
status-firefox16: --- → affected
Target Milestone: --- → mozilla17
(Assignee)

Comment 4

5 years ago
Comment on attachment 642737 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 765956
User impact if declined: wrong website behavior
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low, restoring old behavior
Attachment #642737 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1a3441f550c0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
Comment on attachment 642737 [details] [diff] [review]
fix

[Triage Comment]
Low risk html5 video player fix for a regression in FF16. Approved for Aurora 16.
Attachment #642737 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-firefox16: ? → +
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/b7078bf947ea
status-firefox16: affected → fixed
Verified fixed on FF 16.0a2 (2012-07-30):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
Status: RESOLVED → VERIFIED
status-firefox16: fixed → verified
You need to log in before you can comment on or make changes to this bug.