Closed Bug 774014 Opened 9 years ago Closed 9 years ago

Intermittent test_0201_app_launch_apply_update.js, test_0201_app_launch_apply_update_svc.js | launch application timer expired

Categories

(Toolkit :: Application Update, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
firefox21 --- fixed
firefox-esr17 --- fixed

People

(Reporter: RyanVM, Assigned: robert.strong.bugs)

References

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=13542373&tree=Mozilla-Inbound

Rev3 WINNT 5.1 mozilla-inbound pgo test xpcshell on 2012-07-14 17:50:20 PDT for push d3f19e4f90e7
slave: talos-r3-xp-022

TEST-INFO | c:/talos-slave/test/build/xpcshell/tests/toolkit/mozapps/update/test_svc/unit/test_0201_app_launch_apply_update_svc.js | [switchApp : 184] launching C:\WINDOWS\System32\cmd.exe /D /Q /C c:\docume~1\cltbld\locals~1\temp\tmpp3ir74\ExecutableDir.tmp\bin\0201_svc_aus_test_app.exe -no-remote -process-updates 1> c:\talos-slave\test\build\xpcshell\tests\toolkit\mozapps\update\test_svc\unit\0201_svc_app_console_log 2>&1

TEST-UNEXPECTED-FAIL | c:/talos-slave/test/build/xpcshell/tests/toolkit/mozapps/update/test_svc/unit/test_0201_app_launch_apply_update_svc.js | launch application timer expired - See following stack:
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_throw :: line 451
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/mozapps/update/test_svc/unit/test_0201_app_launch_apply_update_svc.js :: TC_notify :: line 265

TEST-INFO | (xpcshell/head.js) | exiting test
TEST-INFO | c:/talos-slave/test/build/xpcshell/tests/toolkit/mozapps/update/test_svc/unit/test_0201_app_launch_apply_update_svc.js | [PO_observe : 243] topic process-finished, process exitValue 0
TEST-INFO | c:/talos-slave/test/build/xpcshell/tests/toolkit/mozapps/update/test_svc/unit/test_0201_app_launch_apply_update_svc.js | [end_test : 218] removing update test directory c:\docume~1\cltbld\locals~1\temp\tmpp3ir74\ExecutableDir.tmp\bin\update_test
I got this locally, tried to debug but could no longer reproduce. I'm running win7 x64.
Blocks: bgupdates
It was an x86 build by the way.
Whiteboard: [orange]
https://tbpl.mozilla.org/php/getParsedLog.php?id=18576870&tree=Mozilla-Beta
Summary: Intermittent test_0201_app_launch_apply_update_svc.js | launch application timer expired → Intermittent test_0201_app_launch_apply_update.js, test_0201_app_launch_apply_update_svc.js | launch application timer expired
Pushed a possible fix to mozilla-inbound as part of bug 814535
https://hg.mozilla.org/integration/mozilla-inbound/rev/1c7e425e6958

Going to leave this bug open and check back in a week.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Whiteboard: [leave open]
Pushed followup to mozilla-inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/855cac1a1b9a

will push elsewhere later
Note to self and others watching... the test failure on fx-team in comment #41 does not contain the changes pushed in comment #39 and comment #40
Depends on: 814535
No new reports in this bug or bug 814535 since bug 814535 has landed so resolving fixed.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Whiteboard: [leave open]
You need to log in before you can comment on or make changes to this bug.