nsTextControlFrame::ValueSetter has some unused fields

RESOLVED DUPLICATE of bug 774038

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 774038
6 years ago
5 years ago

People

(Reporter: heycam, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
clang warns:

/Volumes/Data/moz/central/layout/forms/nsTextControlFrame.h:213:25: warning: private field 'mFrame' is not used [-Wunused-private-field]

But also, mCancel is not usefully used.  The only use of nsTextControlFrame::ValueSetter that I see is in content/html/content/src/nsTextEditorState.cpp.  I don't know if it is expecting that calling Cancel() should be doing something useful.
(Reporter)

Updated

6 years ago
Blocks: 187528
Looks like these were removed by bug 774038.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 774038
You need to log in before you can comment on or make changes to this bug.