GroupedRating statistics not working

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: vcarciu, Assigned: basta)

Tracking

({regression})

regression
Points:
---

Details

(Reporter)

Description

6 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0

Steps to reproduce:
1.Go to MP and open one app with reviews added.
2.Open reviews section in order to see all reviews
3.Under app title, click the <<number of reviews>> link

Expected results:
Reviews statistics dropdown menu is displayed(number of ratings based on given stars)

Actual results:
For some apps this action is not working

Please see screencast for this bug: http://screencast.com/t/eaN9ivgENVYA

NOTE:
This issue is NOT reproducible for all apps. I observed that if we have an app where the issue is reproducible, if we add a review then everything will work as expected, but we should be able to see this section even if there are reviews only from another users.
Blocks: 746765
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 1

6 years ago
Victor: Can you post some examples of apps that do and don't exhibit this problem?
(Assignee)

Updated

6 years ago
Assignee: nobody → mattbasta
Regression from https://github.com/mozilla/zamboni/commit/f0813d5
Keywords: regression
Summary: Review statistics not working for some apps. → GroupedRating statistics not working
(Reporter)

Comment 3

6 years ago
Matt :
I investigated this issue and I observed that the issue is reproducible for ALL apps if no new review is added. After adding a review, GroupedRating works as expected.
(Assignee)

Comment 4

6 years ago
Fixed by Good Guy Wraithan:

https://github.com/mozilla/zamboni/commit/3af2dabbcc3a51b986b5c10896e7c460d4ab9879
https://github.com/mozilla/zamboni/commit/f67a5ea0c228de2de9f0b3364285d78a40d782a8
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Verified as fixed : http://screencast.com/t/m18WCaZ9ebE2
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

6 years ago
Reproducible again as described in comment #3.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

6 years ago
Should be fixed again:

https://github.com/mozilla/zamboni/commit/46a5eed9dcb6252457b08db6ea793f9c8b2dc93d
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

6 years ago
Verified as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.