Arabic page is redirected to the English one on ICS devices

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: ioana.chiorean, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Build ID: 14.0.1 Release Candidate
Device: Samsung Galaxy Nexus
OS: Android 4.0.4

Steps to reproduce:
1. Go to http://fa.www.mozilla.com/fa/firefox/

Expected result:
- The Arabic page is displayed

Actual result: 
- You are redirected to the English one 

Note:
- this is only reproducible on ICS phones.
(In reply to Ioana Chiorean from comment #0)
> Build ID: 14.0.1 Release Candidate
> Device: Samsung Galaxy Nexus
> OS: Android 4.0.4
> 
> Steps to reproduce:
> 1. Go to http://fa.www.mozilla.com/fa/firefox/
> 
> Expected result:
> - The Arabic page is displayed
> 
> Actual result: 
> - You are redirected to the English one 
> 
> Note:
> - this is only reproducible on ICS phones.

The page has not been localized yet so this is expected.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Raymond: This page is localised. Not on Bedrock yet but still.

Ioana: We don't support URLs starting with the locale. Where does http://www.mozilla.org/fa/firefox/ redirects you?
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 3

6 years ago
Same page, the English version.
I have already states that this occurs only on ICS (Android 4.0 ) devices. Other devices will lead you to Arabic page (so the page exist and URLs starting with the locale will direct you to corresponding locale page).
We'll need a bit more specifics for this.

What is the URL of the page you are redirected to?
What is the User Agent of the browser you're using? You can use http://whatsmyuseragent.com/ to get this information.
(Reporter)

Comment 5

6 years ago
I am redirected to : http://www.mozilla.org/en-US/firefox/fx/?mobile_no_redirect=1
User agent: Mozilla/5.0 (Android; Mobile; rv:14.0) Gecko/14.0 Firefox/14.0.1 (RC Build)
It is also reproducible on Nightly (Mozilla/5.0 (Android; Mobile; rv:16.0) Gecko/16.0 Firefox/16.0)
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
I cannot reproduce the issue now.

http://fa.www.mozilla.com/fa/firefox/
-> http://www.mozilla.org/fa/firefox/
-> http://www.mozilla.org/fa/firefox/new/
Status: NEW → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.