PSM crashes on all secure sites.

VERIFIED INVALID

Status

--
critical
VERIFIED INVALID
18 years ago
2 years ago

People

(Reporter: DJGM1974, Assigned: ddrinan0264)

Tracking

Other Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Whenever using Mozilla, (currently on v0.8.1), anytime I try
to access a secure https website, or secure newsgroup, I 
always get the follwing error message dialog boxes:

1. PSM has generated errors and will shut down by Windows.
   You will need to restart the program.

This is then followed by:
2. The connection was refused when trying to contact . . .
   www.ebank.hsbc.co.uk

As this happens with all secure sites, I have used the HSBC
site URL as an example of a secure site I use regularly.

Additionally, since I installed Mozilla 0.8.1, the same 
problem has also spread to my installation of Netscape6.
I have both Mozilla and Netscape 6 are installed in the 
default folders, as specified in each programs installer.

I have attempted uninstalling and reinstalling both of these
applications, and also clearing the entries in the Windows
registry before reinstalling either program.

Comment 1

18 years ago
"PSM has generated errors and will shut down by Windows"
If you are getting this error message, search your drives for psm.exe, and 
delete it and the folder that it is in. psm.exe is no longer used.
Try this build - it contains PSM 2.0 (in-process) and works fine on SSL sites.
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Don't you also have to remove psm-glue?

Should we be trying to get the installer to remove PSM 1?

Comment 3

18 years ago
Marking invalid. With a clean install, PSM 2.0 works does not crash on secure 
sites.

I've opened bug Bug 77927 to address the issure of removing psmglue.dll during 
an upgrade.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 4

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.