Closed Bug 774351 Opened 9 years ago Closed 7 years ago

Unified Inbox Folder Broken (message previews blank, inbox entirely unusable as of 13.0.1 update). Component returned failure code: 0x80550005 [nsIMsgFolder.msgDatabase

Categories

(Thunderbird :: Folder and Message Lists, defect)

13 Branch
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 28.0

People

(Reporter: moz_bugzilla, Assigned: aceman)

References

Details

Attachments

(2 files, 4 obsolete files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

I'm on OSX 10.7.4 and I recently updated from 13.0 to 13.0.1. Since the update I've noticed two specific problems, although I'll only describe the main problem with the unified inbox on this ticket (I mention there are two problems in case they are connected - I'll file another bz separately for the other issue regarding my main address book being missing/corrupted/not working as expected).


Actual results:

The unified inbox views (both of them: the "Local Folders - Global Inbox" and the "Inbox" parent of my 5 email accounts) no longer function. Since the dot-update attempting to use either unified view fails: when selecting the unified view there's a funny new component near my cursor, the pane that shows the subject lines (name?) does not refresh, and mousing over any [now stale] email in that pane causes an explicit refresh of that line from whatever it was to an entirely blank line. The blank line is not clickable in any way and cannot be interacted with at all.


Expected results:

The upper right pane (again, name?) should have refreshed with a unified inbox view.
I'm adding another bug that also manifested for me with the 13 -> 13.0.1 update just in case they are intertwined.
See Also: → 774359
Did you try with Thunderbird started with addon disabled (help -> restart ...) ?

Anything in Tools->Error console ?
Component: General → Folder and Message Lists
Yes. I have the same behavior with "addons disabled." I do not use any custom Appearance addons. It should be moot, but here are the 8 Extensions I have installed:

(1) Enigmail 1.4.3
(2) Folderpane Tools 0.6.1
(3) Lightning 1.6
(4) LookOut 1.2.13
(5) Message Archive Options 5.0.0
(6) Provider for Google Calendar 0.13
(7) Test Pilot for Thunderbird 1.3.9
(8) Thunderbird Conversations 2.4.3
And nothing in the console ?
(In reply to Ludovic Hirlimann [:Usul] from comment #4)
> And nothing in the console ?

Interesting - I didn't know about the GUI debugging console. Here's what happens when I mouseover the unified inbox folder (literally the word, "INBOX"). Note that the odd yellow square I mentioned in the attachment shows up when this error get's generated:
[code]
Timestamp: 9/24/12 10:01:21 AM
Error: Component returned failure code: 0x80550005 [nsIMsgFolder.msgDatabase]
Source File: chrome://messenger/content/mailWidgets.xml
Line: 2496
[/code]

There are no further errors or warnings when I mouseover individual emails.
Severity: normal → major
Summary: Unified Inbox Broken (message previews blank, inbox entirely unusable as of 13.0.1 update) → Unified Inbox Folder Broken (message previews blank, inbox entirely unusable as of 13.0.1 update). Component returned failure code: 0x80550005 [nsIMsgFolder.msgDatabase
Whiteboard: [dupeme?]
FWIW I'm on the same profile but have upgraded to 17.0.5 now. I still don't have a unified inbox, but the behavior is different now: the inbox is just blank (empty). I no longer have the little yellow boxes.
This is a copy of reporter's attachment 642636 [details] in a more accessible file format (jpg instead of jpf/jpg-2000). Pls use jpg, gif or png for screenshots.
Attachment #642636 - Attachment is obsolete: true
Attachment #735291 - Attachment description: Screenshot 1a+b: Screen refresh problems in message pane (in order of occurence) → Screenshot 1a+b: Screen refresh problems in message pane (in order of occurence), provided by reporter in comment 0
If this was a general problem of unified folders, I think we'd see this more often in bugs (haven't seen any dupes, haven't checked). My unified folders on WinXP/TB17.05 seem to work as they are currently designed, but generally I don't use unified folders. We've had screen refresh problems in message pane in other scenarios (grouped by sort), but I don't think that's related.
I have identified that the small yellow rectangle happens when mousing over a folder when that folder is missing its .msf file database. So this patch solves that one. It seems the tooltip just shows summary of new messages so we can skip that in case the folder is broken like this. Also, clicking/opening the folder makes it rebuild the .msf so that is when the real problem gets fixed.
Attachment #766421 - Flags: review?(mbanner)
This one should be better.
Attachment #766421 - Attachment is obsolete: true
Attachment #766421 - Flags: review?(mbanner)
Attachment #766428 - Flags: review?(mkmelin+mozilla)
Attachment #766428 - Flags: review?(mbanner)
Comment on attachment 766428 [details] [diff] [review]
patch for the exception on mouse over folder v2

Review of attachment 766428 [details] [diff] [review]:
-----------------------------------------------------------------

Or maybe use folder.getDBFolderInfoAndDB to get it "fixed" straight away?
Assignee: nobody → acelists
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 766428 [details] [diff] [review]
patch for the exception on mouse over folder v2

I think I'm with Magnus that getDBFolderInfoAndDB seems to be the right thing to use.
Attachment #766428 - Flags: review?(mbanner)
Comment on attachment 766428 [details] [diff] [review]
patch for the exception on mouse over folder v2

r- per previous comment
Attachment #766428 - Flags: review?(mkmelin+mozilla) → review-
I haven't seen any noticeable difference with this function, but if you wish I can use it.
Attachment #766428 - Attachment is obsolete: true
Attachment #776653 - Flags: review?(mkmelin+mozilla)
Comment on attachment 776653 [details] [diff] [review]
patch for the exception on mouse over folder v3

Review of attachment 776653 [details] [diff] [review]:
-----------------------------------------------------------------

The idea was that with this you don't have to try/catch anything, as it never throws - http://mxr.mozilla.org/comm-central/source/mailnews/base/public/nsIMsgFolder.idl#472
(Would be good to add that to the doc of the attribute too...)
Attachment #776653 - Flags: review?(mkmelin+mozilla) → review-
I don't think "may not" means "must not" as in "never ever throws".
And I think the code says that too, e.g.:
http://mxr.mozilla.org/comm-central/source/mailnews/imap/src/nsImapMailFolder.cpp#2025

It is full of returns of rv.
In my test with the deleted .msf I saw no difference in behaviour of msgDatabase and GetDBFolderInfoAndDB (and the msf was not generated when GetDBFolderInfoAndDB was called).
Flags: needinfo?(mkmelin+mozilla)
Hm, that comment is misleading then. I guess the original patch is preferable then.
Flags: needinfo?(mkmelin+mozilla)
I found a workaround that seems to solve this problem for both Windows and Mac clients that apparently still have this problem in Thunderbird 24.0.1:

1. In Thunderbird, select View -> Folders -> All from the menus (yes, turn off Unified folders if it is already selected)
2. Quit out of Thunderbird
3. Locate and delete (or rename) the User's "smart mailboxes" folder inside the Thunderbird Profile (on a Mac it is found at /Users/username/Library/Thunderbird/Profiles/default.emc/Mail/smart mailboxes
4. Run Thunderbird
5. Select View -> Folders -> Unified from the menus.

That fixed it for me. It must be done exactly as above and in that order or it won't work.
In that case both patches (v2 and v3) are almost the same. Maybe Neil will know which function is better and what the actual behaviour is.
Flags: needinfo?(neil)
(In reply to aceman from comment #16)
> I don't think "may not" means "must not" as in "never ever throws".
> And I think the code says that too, e.g.:
> http://mxr.mozilla.org/comm-central/source/mailnews/imap/src/
> nsImapMailFolder.cpp#2025
> 
> It is full of returns of rv.
> In my test with the deleted .msf I saw no difference in behaviour of
> msgDatabase and GetDBFolderInfoAndDB (and the msf was not generated when
> GetDBFolderInfoAndDB was called).

GetDBFolderInfoAndDB will fail at least as often as GetMsgDatabase will, since in both nsLocalMailFolder and nsImapMailFolder the functions start with the same calls. (GetDBFolderInfoAndDB also has to get the DBFolderInfo of course, which could result in an additional exception.)
Flags: needinfo?(neil)
Mkmelin, can we proceed with the patch now? Should I tweak some comment in it?
Flags: needinfo?(mkmelin+mozilla)
Comment on attachment 766428 [details] [diff] [review]
patch for the exception on mouse over folder v2

Review of attachment 766428 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/base/content/mailWidgets.xml
@@ +2421,5 @@
> +            try {
> +              msgDatabase = aFolder.msgDatabase;
> +            } catch(e) {
> +              // The database for this folder may be missing (e.g. outdated/missing .msf),
> +              // then just skip this folder.

then -> so, here and the other place
Attachment #766428 - Flags: review- → review+
Attachment #766428 - Attachment is obsolete: false
Flags: needinfo?(mkmelin+mozilla)
Attached patch patch v4Splinter Review
OK, so if you prefer version v2 I unbitrotted it and added proper commit message. Carrying over r+.
Attachment #766428 - Attachment is obsolete: true
Attachment #776653 - Attachment is obsolete: true
Attachment #824275 - Flags: review+
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: checkin-needed
Whiteboard: [dupeme?]
https://hg.mozilla.org/comm-central/rev/4f902dd8fa8d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 28.0
You need to log in before you can comment on or make changes to this bug.