Intermittent test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0, frequently followed by indexedDB failures

RESOLVED FIXED in Firefox 17

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: emorley, Assigned: dougt)

Tracking

({intermittent-failure})

Trunk
mozilla18
x86_64
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.48 KB, patch
smaug
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
Rev3 Fedora 12x64 mozilla-inbound pgo test mochitests-2/5 on 2012-07-16 04:04:24 PDT for push 082542b01af8

slave: talos-r3-fed64-004

https://tbpl.mozilla.org/php/getParsedLog.php?id=13569339&tree=Mozilla-Inbound

{
2402 INFO TEST-START | /tests/dom/devicestorage/test/test_basic.html
2403 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have getDeviceStorage
2404 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have gotten a storage
2405 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have a non-null request
2406 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0
2407 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | File name should match
2408 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | addSuccess was called
2409 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have getDeviceStorage
2410 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | File name should match
2411 INFO TEST-END | /tests/dom/devicestorage/test/test_basic.html | finished in 50ms
}
(Reporter)

Comment 1

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=13575589&tree=Mozilla-Inbound

{
2402 INFO TEST-START | /tests/dom/devicestorage/test/test_basic.html
2403 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0
2404 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0
2405 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_basic.html | an unexpected uncaught JS exception reported through window.onerror - Script error. at resource:///components/BrowserElementParent.js:0
2406 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have getDeviceStorage
2407 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have gotten a storage
2408 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have a non-null request
2409 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | File name should match
2410 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | addSuccess was called
2411 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | Should have getDeviceStorage
2412 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | File name should match
2413 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | wrong arraybuffer byteLength - 69 should equal 69
2414 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | wrong values - My name is Doug Turner.  My IRC nick is DougT.  I like Maple cookies. should equal My name is Doug Turner.  My IRC nick is DougT.  I like Maple cookies.
2415 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | File name should match
devicestorage/hi
2416 INFO TEST-PASS | /tests/dom/devicestorage/test/test_basic.html | file was deleted successfully
2417 INFO TEST-END | /tests/dom/devicestorage/test/test_basic.html | finished in 58ms
}
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Assignee: nobody → doug.turner
jlebar added a mechanism to test for dead windows in bug 773980 to fix a similar problem that may be useful here.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 30

5 years ago
Created attachment 645197 [details] [diff] [review]
patch v.1

This seems to work:  https://tbpl.mozilla.org/?tree=Try&rev=1a74a5b68e17
Attachment #645197 - Flags: review?(justin.lebar+bug)
Won't this simply change the can't-touch-dead-object errors into null-pointer errors, which would still turn the tree orange?
(Assignee)

Comment 32

5 years ago
I didn't see any null-pointer errors when I retriggered this patch a few times here:

  https://tbpl.mozilla.org/?tree=Try&rev=1a74a5b68e17

Where would you expect to see null-pointer errors?
> Where would you expect to see null-pointer errors?

From the same place as whoever was touching the dead object.

Before you nulled out the object, someone touched it and triggered an error.  Now when they go to touch it, the object is null, which likewise triggers an error.  Nothing else in this test changed except the value gDataBlob/gFileReader after unload, and the type of exception thrown when you touch the variable, right?  I don't understand how that should fix anything.

I mean, it obviously appears to work.  I just don't understand why, unless the dead-object error was caused by someone calling tostring on the dead object, which won't throw for the null object.
Comment on attachment 645197 [details] [diff] [review]
patch v.1

:shrug:
Attachment #645197 - Flags: review?(justin.lebar+bug) → review+
(Assignee)

Comment 35

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f47a908ed9d2
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 39

5 years ago
https://hg.mozilla.org/mozilla-central/rev/f47a908ed9d2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
Comment hidden (Treeherder Robot)
(Reporter)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
(Assignee)

Comment 42

5 years ago
bah
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: Intermittent test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0 → Intermittent test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0, frequently followed by indexedDB failures
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 89

5 years ago
Doug, any news on this? (is a top orange)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 164

5 years ago
Created attachment 658957 [details] [diff] [review]
patch v.2

So, we have a recording of the failure, but haven't had time to sit down and debug it further.  We know that onTestMessage is being called after onTestComplete.


This is a hopeful bandaide that will removed all of the mm listeners during onTestComplete.
Attachment #645197 - Attachment is obsolete: true
Attachment #658957 - Flags: review?(bugs)
(Assignee)

Updated

5 years ago
Attachment #658957 - Attachment is obsolete: true
Attachment #658957 - Flags: review?(bugs)
(Assignee)

Updated

5 years ago
Attachment #658957 - Attachment is obsolete: false
Attachment #658957 - Flags: review?(bugs)
Comment on attachment 658957 [details] [diff] [review]
patch v.2

rs=me
Attachment #658957 - Flags: review?(bugs) → review+
(Assignee)

Comment 166

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/16a30bcf73d7
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

5 years ago
Target Milestone: mozilla17 → mozilla18
(Reporter)

Comment 169

5 years ago
https://hg.mozilla.org/mozilla-central/rev/16a30bcf73d7
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 789008
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 196

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/999132c33e6d
status-firefox17: --- → fixed
Comment hidden (Treeherder Robot)
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.