My Netscape Edit Personal Finance unusable

VERIFIED DUPLICATE of bug 77321

Status

()

Core
Event Handling
--
major
VERIFIED DUPLICATE of bug 77321
17 years ago
7 years ago

People

(Reporter: Marek Z. Jeziorek, Assigned: joki (gone))

Tracking

Trunk
mozilla0.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: worksforme?, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
using build 2001042408
go to http://mybeta.netscape.com/index2.psp or even to http://my.netscape.com/
press Edit button on Personal Finance
obeserve transfering, resolving, connecting done forever
Oh boy, you just get popup window that flashes, and there is no way you can edit
anything. Nominating for nsbeta1. I am not sure who should own this bug, adding
pollmann and jst to Cc. Moving to 0.9.1.

The popup page is totally whacked! Who could teach Netscape.com people to write
even remotely decent HTML (*sob*), there are even two top level elements for
crying out loud? I'll attach the HTML of the page.

The page is messing up with document.location, so I am guessing this might
actually be a duplicate. It also seems to create frameset documents via scripts.
Keywords: nsbeta1
Summary: infinite loop → My Netscape Edit Personal Finance unusable
Target Milestone: --- → mozilla0.9.1
Created attachment 33083 [details]
Edit Personal Finance HTML source
(Assignee)

Comment 3

17 years ago
Just for the sake of info, I don't actually think this is mine.  But its a hard 
one to break down.

Comment 4

17 years ago
nsbeta1+
Some fix for this is needed, as is a correct owner.  We should not ship beta
with Personal Finance broken.
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Comment 5

17 years ago
Looking at this again the behavior has changed.  The original behavior described 
 in the first bug description isn't there anymore.  You now get the popup and 
the behavior heikki describes.  The orginal behavior seemed network related but 
I think this new behavior is due to resize event behavior and would be mine.  
Looking further.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

17 years ago
Okay, there seems to be two bugs in this currently.  One is a dupe of the resize 
event bug 77321.  The second is a bug related to the XPCDOM landing which will 
not allow certain named window level properties to be overridden by local 
variables.  In this case, the 'sidebar' property fails.  jst gave me a local 
patch for this and it works for me.  After the resize fix goes in I'll give this 
to jst if this still doesn't work.
Whiteboard: worksforme?
The XPCDOM related problems that were seen here should be fixed now, let me know
if that's not the case.
(Assignee)

Comment 8

17 years ago
Marking dupe of resize at this point since jst's fix is in.

*** This bug has been marked as a duplicate of 77321 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
verified dups
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.