crash in nsStorageInputStream::ReadSegments @ _VEC_memcpy since Firefox 13 or earlier

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
--
critical
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: briansmith, Unassigned)

Tracking

({crash})

13 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

+++ This bug was initially created as a clone of Bug #764171 +++

Bug 764171 is about a new fault with the same signature that I introduced in Firefox 15. However, there are less-frequently-occuring crashes in Firefox 13 and 14 that indicate there's a different codepath causing crashes with this same signature.
No longer blocks: 539040, 746018, 769565
status-firefox15: disabled → ---
status-firefox16: fixed → ---
tracking-firefox15: + → ---
tracking-firefox16: + → ---
No longer depends on: 770243
Keywords: regression, topcrash
Summary: crash in nsStorageInputStream::ReadSegments @ _VEC_memcpy since Firefox 13 → crash in nsStorageInputStream::ReadSegments @ _VEC_memcpy since Firefox 13 or earlier

Updated

3 years ago
Crash Signature: [@ _VEC_memcpy | nsStorageInputStream::ReadSegments(unsigned int (*)(nsIInputStream*, void*, char const*, unsigned int, unsigned int, unsigned int*), void*, unsigned int, unsigned int*) ] [@ memcpy | nsStorageInputStream::ReadSegments(unsigned int… → [@ _VEC_memcpy | nsStorageInputStream::ReadSegments(unsigned int (*)(nsIInputStream*, void*, char const*, unsigned int, unsigned int, unsigned int*), void*, unsigned int, unsigned int*) ] [@ memcpy | nsStorageInputStream::ReadSegments(unsigned int…
only one of these in current crashstats and its on gecko 16
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.