DOM bindings don't get rebuilt if their dependencies change but the text doesn't change

RESOLVED DUPLICATE of bug 784812

Status

RESOLVED DUPLICATE of bug 784812
6 years ago
7 months ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I did the following:

* edit dom/bindings/Bindings.conf.
* edit dom/webidl/Perfromance*.webidl
* make -C objdir/dom

make finished running without rebuilding anything.
Hmm.  Bindings.conf is explicitly listed in bindinggen_dependencies.

Did the changes lead to exactly the same code being generated?  There's some weirdness where we don't create the new C++ and header files if they end up being string-identical to what we used to have....
(Reporter)

Comment 2

6 years ago
(In reply to comment #1)
> Hmm.  Bindings.conf is explicitly listed in bindinggen_dependencies.
> 
> Did the changes lead to exactly the same code being generated?  There's some
> weirdness where we don't create the new C++ and header files if they end up
> being string-identical to what we used to have....

Hmm, maybe.  I was trying to move the infallible annotations to the WebIDL files, and I guess that didn't change the exact code generated, right?  Still, this is totally unintuitive.
Yeah, indeed, moving the annotations wouldn't change the code.

I agree it's screwed up.  I thought Kyle had an existing bug on it...
OK, let's make this that bug, then!
Summary: Changing dom/bindings/Bindings.conf and dom/webidl/foo.webidl doesn't trigger a rebuild → DOM bindings don't get rebuilt if their dependencies change but the text doesn't change
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 784812

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.