Closed Bug 774648 Opened 9 years ago Closed 9 years ago

MultiChoicePreference should grey out the Positive option if no checkboxes are selected

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox15 verified, firefox16 verified, firefox17 verified)

VERIFIED FIXED
Firefox 17
Tracking Status
firefox15 --- verified
firefox16 --- verified
firefox17 --- verified

People

(Reporter: xti, Assigned: bnicholson)

Details

Attachments

(2 files, 1 obsolete file)

Attached image screenshot
Firefox 17.a1 (2012-07-17)
Device: Galaxy Nexus
OS: Android 4.0.4

Steps to reproduce:
1. Open Firefox
2. Go to Menu > Settings > Import from Android
3. Uncheck Bookmarks and History

Expected result:
Import button is grayed out.

Actual result:
Import button is still active, as you can see in the attached screenshot.
Summary: Import button is still active if all options were unchecked in Import from Android feature → MultiChoicePreference should grey out the Positive option if no checkboxes are selected
On import, I see I/AndroidImport(n): Importing Android history/bookmarks, but no items are imported.
You'll get that message if the routine is activated, no matter if it ends up doing anything or not.
It's possible we may still want to show a dialog where the button can be clicked even if all options are deselected, but we can just address that if/when we need it in the future.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #643110 - Flags: review?(mark.finkle)
Some minor changes (uses break instead of early return, and only sets enabled state if it has changed).2
Attachment #643110 - Attachment is obsolete: true
Attachment #643110 - Flags: review?(mark.finkle)
Attachment #643114 - Flags: review?(mark.finkle)
Comment on attachment 643114 [details] [diff] [review]
Enable positive button in MultiChoicePreference only if items are checked, v2

Need uplift to aurora and beta?
Attachment #643114 - Flags: review?(mark.finkle) → review+
Comment on attachment 643114 [details] [diff] [review]
Enable positive button in MultiChoicePreference only if items are checked, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 754335
User impact if declined: use can choose to clear private data or import from Android without anything checked
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #643114 - Flags: approval-mozilla-beta?
Attachment #643114 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d3fc89f462d2
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Attachment #643114 - Flags: approval-mozilla-beta?
Attachment #643114 - Flags: approval-mozilla-beta+
Attachment #643114 - Flags: approval-mozilla-aurora?
Attachment #643114 - Flags: approval-mozilla-aurora+
Depends on: 776909
It should be backed out from 15.0b2 because of the regression.
No longer depends on: 776909
Based on Brian's dependency cut, forget comment 11.
Confused, I see this landed on mozilla-beta, but the changes are not in the mozilla-beta (15, beta 2, build #1) build. What happened?
Confirmed, verifying this by using the 'Clear private data' popup.
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.