A useless "Welcome to Firefox" page is shown after updating to version 14

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I just updated to Firefox 14 and it shows me a "Welcome to Firefox" page containing the same video that was shown for the version 13 release.

This page seems to be quite unnecessary. Is it really necessary to show it to the user?

I was under the impression that Firefox wanted to do updates "silently", but showing this tab with no new information goes against that concept.

Suggestion is to no longer show this page if it has nothing new to present. Or not show it at all.
(Reporter)

Updated

6 years ago
Summary: A not so useful "Welcome to Firefox" page is shown after updating to version 14 → A useless "Welcome to Firefox" page is shown after updating to version 14
(Reporter)

Comment 1

6 years ago
Didn't see this page after updating to Firefox 17.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.