If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Aurora Crashes when opening twitter

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jrconlin, Unassigned)

Tracking

({crash})

15 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I get repeated crashes when opening twitter with Aurora. Most of the page displays, however the browser crashes after a few seconds during a load.

This article may help:
http://my.opera.com/hallvors/blog/2012/07/17/twitter-crashes-itself-with-commas

I don't experience this problem in nightly, so this may be a known issue.

Comment 1

5 years ago
Can you provide the crash ID from about:crashes?
Severity: normal → blocker
Keywords: crash

Updated

5 years ago
Severity: blocker → critical
(Reporter)

Comment 2

5 years ago
Crap, sorry! Forgot to add that:

 29a4b61d-8dd7-45fd-a530-00f0d2120717

(also: 9dbff7be-1fc9-4640-ab66-21d192120717)

Comment 3

5 years ago
In a linkable way: bp-29a4b61d-8dd7-45fd-a530-00f0d2120717, bp-9dbff7be-1fc9-4640-ab66-21d192120717.

You have a bunch of installed extensions. Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Does it happen with a new profile (see https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles)?
Does it happen in Nightly?
This kind of signature moves with each build. Can you attach a valid stack trace (see https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report#Alternative_ways_to_get_a_stacktrace)?
Crash Signature: [@ mozalloc_abort(char const* const) | xul.dll@0x960c66 | xul.dll@0x310b49 | xul.dll@0x7cc00a | xul.dll@0x3e513d | js::TokenStream::reportCompileErrorNumberVA(js::ParseNode*, unsigned int, unsigned int, char*)]
(Reporter)

Comment 4

5 years ago
In Safe Mode:
Twitter does not crash browser, I do get: the following in the error console:

Timestamp: 7/17/2012 1:44:18 PM
Error: too much recursion
Source File: https://twimg0-a.akamaihd.net/c/phoenix/en/bundle/t1-core.29d40e420c0f183c9af44bf4360e3557.js
Line: 30

Twitter page does not fully render. (see attached)

With new profile:
Page loads successfully.

With Nightly:
Page loads successfully. 

Will investigate on this side to determine which plugin may be causing the error. Thanks!
(Reporter)

Comment 5

5 years ago
Created attachment 643128 [details]
Incomplete page load screen cap
(Reporter)

Comment 6

5 years ago
Odd. Just enabled each add-on one by one and was not able to duplicate crash. Twitter now loading correctly with all add-ons enabled. 

May have to close bug as Can't Reproduce.
(In reply to JR Conlin [:jrconlin,:jconlin] from comment #6)
> Odd. Just enabled each add-on one by one and was not able to duplicate
> crash. Twitter now loading correctly with all add-ons enabled. 
> 
> May have to close bug as Can't Reproduce.

Sure, closing for now. Please reopen if it comes back.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.