Firefox is High CPU usage waiting on an unresponsive website (probably UI refresh), on slow satellite connection. Not really battery life friendly

RESOLVED DUPLICATE of bug 508427

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 508427
6 years ago
3 years ago

People

(Reporter: Francois Guerraz, Unassigned)

Tracking

({perf})

14 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

(Basically following one of my comments in #482642)

Using FF 14.0.1 on Mac OSX Lion on a very slow connection (I'm on a satellite link) and just waiting on an unresponsive website (on a SYN_SENT, no established connection) uses 15%CPU (on a i7!), minimizing the window helps (CPU drops down to <5%).

Downloading a file at 3kb/s for example uses 15%CPU too, basically doing nothing !
I suspect the usage comes from the UI refreshing the download progress bar or just the spinning wheel in the tab which is *ridiculous* because it wakes up the CPU very often and halves my battery life!

This doesn't happen in Safari.

Would be nice to fix or, if it's UI related, have a configuration option (lowering the eye-candy refresh rate?) for those who prefer battery life over abusive UI refreshing! :)

Updated

6 years ago
Component: Untriaged → General
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508427

Comment 2

3 years ago
Francois, do you still see this problem when using a current version of Firefox?


> I suspect the usage comes from the UI refreshing the download progress bar or just the spinning wheel in the tab which is *ridiculous* because it wakes up the CPU very often and halves my battery life!

iirc there were such problems in the time frame of your report. So I'm not sure this is a proper duplicate of bug 508427
Flags: needinfo?(kubrick)
Keywords: perf
Summary: Firefox is High CPU usage (probably UI refresh) not really battery life friendly → Firefox is High CPU usage waiting on an unresponsive website (probably UI refresh), on slow satellite connection. Not really battery life friendly
(Reporter)

Comment 3

3 years ago
Yes, this is still happenning with 43.0a2 (2015-10-16).
Just try to connect to a IP/port that just DROP packets or download a large file from a repository on the other side of the planet.
Flags: needinfo?(kubrick)
You need to log in before you can comment on or make changes to this bug.