Warn about Jetpack 1.8 add-ons which access 'options.loadReason'

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Add-on Validation
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: kmag, Unassigned)

Tracking

Details

(Whiteboard: [ReviewTeam])

(Reporter)

Description

6 years ago
Add-ons built with Jetpack 1.8 which access options.loadReason are likely to break. There needs to be a warning that they should update to at least version 1.8.1:

https://blog.mozilla.org/addons/2012/07/10/announcing-add-on-sdk-1-8-1/

I'm not sure how to best implement this. We should probably just do a regexp or substring test for the string if the add-on is using Jetpack 1.8. The only other option I can think of is to paint the first argument of any function when it's assigned to export.main, which seems infeasible.
(Reporter)

Updated

6 years ago
Whiteboard: [ReviewTeam]
Old bug, no longer relevant.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.