Last Comment Bug 774731 - Previous conversations sometimes not displayed
: Previous conversations sometimes not displayed
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 17.0
Assigned To: Florian Quèze [:florian] [:flo]
: instant-messaging
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 10:10 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-07-27 13:45 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
Patch (5.31 KB, patch)
2012-07-17 10:10 PDT, Florian Quèze [:florian] [:flo]
mconley: review+
bwinton: approval‑comm‑aurora+
bwinton: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] 2012-07-17 10:10:06 PDT
Created attachment 643016 [details] [diff] [review]
Patch

I've debugged a few cases where the "Daily currently doesn't have any previous conversations stored for this contact." panel was displayed instead of an existing previous conversation.

It happened when selecting a contact with a previous conversation, then a contact without previous conversation, then selecting the contact with a previous conversation again. This is because in my patch for bug 754914 I prevented redisplaying a previous conversation if it was already displayed in the browser, but I forgot to still ensure the log panel is visible.

The same thing can happen for the "Search result" item: the log panel isn't always shown correctly when reselecting that item.

And a last case causing a similar problem: closing the "search result" conversation, which actually just hides it. This attempts to select another conversation, but the mousedown event handler of listbox.xml immediately reselects it even though it is hidden, so when displaying it again the 'select' event isn't fired, as the item is already selected.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-07-18 10:10:13 PDT
Comment on attachment 643016 [details] [diff] [review]
Patch

Review of attachment 643016 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good - and I can confirm that this fixes the bug.
Comment 2 Blake Winton (:bwinton) (:☕️) 2012-07-23 11:44:47 PDT
Comment on attachment 643016 [details] [diff] [review]
Patch

Yeah, I really think we want to have this on aurora/beta.

Note You need to log in before you can comment on or make changes to this bug.