Closed Bug 774789 Opened 7 years ago Closed 7 years ago

compile failures in Android 15.0b1 builds

Categories

(Firefox for Android :: General, defect)

15 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 17
Tracking Status
firefox15 --- verified
firefox16 --- verified
firefox17 --- verified

People

(Reporter: bhearsum, Assigned: mbrubeck)

References

Details

(Keywords: regression)

Attachments

(1 file)

Could be branding related:
	  /builds/slave/rel-m-beta-andrd-xul-bld/build/toolkit/mozapps/update/test/unit
/builds/slave/rel-m-beta-andrd-xul-bld/build/obj-firefox/_virtualenv/bin/python /builds/slave/rel-m-beta-andrd-xul-bld/build/config/Preprocessor.py -Fsubstitution -DAB_CD=en-US -DMOZ_APP_NAME=fennec -DMOZ_APP_DISPLAYNAME=Firefox Beta -DBIN_SUFFIX= -DNS_NO_XPCOM -DMOZ_DEBUG=  -DANDROID=1 -DANDROID_VERSION=5 -DCROSS_COMPILE=1 -DMOZ_THUMB2=1 -DHAVE_ARM_SIMD=1 -DHAVE_ARM_NEON=1 -DMOZ_ENABLE_PROFILER_SPS=1 -DMOZILLA_VERSION=\"15.0\" -DMOZILLA_VERSION_U=15.0 -DMOZILLA_UAVERSION=\"15.0\" -DNO_PW_GECOS=1 -DMOZ_LINKER=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_SSIZE_T=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UNAME_DOMAINNAME_FIELD=1 -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE=1 -DHAVE_VISIBILITY_ATTRIBUTE=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_SYSMACROS_H=1 -DHAVE_LINUX_QUOTA_H=1 -DHAVE_MMINTRIN_H=1 -DHAVE_SYS_CDEFS_H=1 -DHAVE_DLOPEN=1 -DHAVE_MEMMEM=1 -DNO_X11=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_CLOCK_MONOTONIC=1 -DMALLOC_H=\<malloc.h\> -DHAVE_STRNDUP=1 -DHAVE_MEMALIGN=1 -DHAVE_VALLOC=1 -DHAVE_I18N_LC_MESSAGES=1 -DNS_ALWAYS_INLINE=__attribute__\(\(always_inline\)\) -DNS_ATTR_MALLOC=__attribute__\(\(malloc\)\) -DNS_WARN_UNUSED_RESULT=__attribute__\(\(warn_unused_result\)\) -DMOZ_BUILD_APP=mobile/xul -DMOZ_WIDGET_ANDROID=1 -DMOZ_PDF_PRINTING=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DUSE_ARM_KUSER=1 -DMOZ_OFFICIAL_BRANDING=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DIBMBIDI=1 -DACCESSIBILITY=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_RAW=1 -DMOZ_OGG=1 -DATTRIBUTE_ALIGNED_MAX=64 -DMOZ_WEBM=1 -DVPX_ARM_ASM=1 -DMOZ_WAVE=1 -DMOZ_SYDNEYAUDIO=1 -DMOZ_SPEEX_RESAMPLER=1 -DMOZ_MEDIA=1 -DMOZ_TREMOR=1 -DMOZ_OPUS=1 -DMOZ_XTF=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DLIBJPEG_TURBO_ARM_ASM=1 -DMOZ_USE_NATIVE_POPUP_WINDOWS=1 -DMOZ_TREE_FREETYPE=1 -DHAVE_FT_BITMAP_SIZE_Y_PPEM=1 -DHAVE_FT_GLYPHSLOT_EMBOLDEN=1 -DHAVE_FT_LOAD_SFNT_TABLE=1 -DMOZ_UPDATER=1 -DMOZ_UPDATE_CHANNEL=beta -DMOZ_DISABLE_DOMCRYPTO=1 -DMOZ_FEEDS=1 -DMOZ_GFX_OPTIMIZE_MOBILE=1 -DMOZ_DEBUG_SYMBOLS=1 -DMOZ_LOGGING=1 -DSIZEOF_INT_P=4 -DMOZ_MEMORY_SIZEOF_PTR_2POW=2 -DMOZ_MEMORY=1 -DMOZ_MEMORY_LINUX=1 -DMOZ_MEMORY_ANDROID=1 -DJSGC_INCREMENTAL=1 -DHAVE__UNWIND_BACKTRACE=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMOZ_OMNIJAR=1 -DMOZ_USER_DIR=\".mozilla\" -DMOZ_STATIC_JS=1 -DMOZ_TREE_PIXMAN=1 -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_GRAPHITE=1 -DMOZ_ENABLE_SKIA=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DBUILD_CTYPES=1 -DMOZ_PLACES=1 -DMOZ_SERVICES_SYNC=1 -DMOZ_APP_COMPONENT_INCLUDE=\"nsBrowserComponents.h\" -DMOZ_MACBUNDLE_ID=org.mozilla.firefox\ beta -DMOZ_APP_UA_NAME=\"\" -DMOZ_APP_UA_VERSION=\"15.0\" -DMOZ_UA_FIREFOX_VERSION=\"15.0\" -DFIREFOX_VERSION=15.0 -DMOZ_UA_BUILDID=\"\" -DMOZ_TELEMETRY_REPORTING=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1  /builds/slave/rel-m-beta-andrd-xul-bld/build/toolkit/mozapps/update/test/unit/head_update.js.in > /builds/slave/rel-m-beta-andrd-xul-bld/build/obj-firefox/toolkit/mozapps/update/test/../../../../_tests/xpcshell/toolkit/mozapps/update/test/unit/head_update.js
Traceback (most recent call last):
  File "/builds/slave/rel-m-beta-andrd-xul-bld/build/config/Preprocessor.py", line 452, in <module>
    main()
  File "/builds/slave/rel-m-beta-andrd-xul-bld/build/config/Preprocessor.py", line 437, in main
    pp.handleCommandLine(None, True)
  File "/builds/slave/rel-m-beta-andrd-xul-bld/build/config/Preprocessor.py", line 139, in handleCommandLine
    self.do_include(f, False)
  File "/builds/slave/rel-m-beta-andrd-xul-bld/build/config/Preprocessor.py", line 405, in do_include
    raise Preprocessor.Error(self, 'FILE_NOT_FOUND', str(args))
__main__.Error: ('', 0, 'FILE_NOT_FOUND', '/builds/slave/rel-m-beta-andrd-xul-bld/build/obj-firefox/toolkit/mozapps/update/test/Beta')
make[7]: *** [libs] Error 1
Product: Fennec → Firefox for Android
I think the problem is the command line arguments "-DMOZ_APP_DISPLAYNAME=Firefox Beta".

"Firefox Beta" is not quoted, so "Beta" is treated as a separate parameter, which is why Preprocessor.py is looking for a file named "Beta" which doesn't exist.
My guess is that those tests should not be run for Mobile
Regression from bug 307181:
http://hg.mozilla.org/mozilla-central/rev/c20d415ef1b5#l25.12

It looks like this was added in multiple places and will need to be fixed in all of them.
Attached patch patchSplinter Review
Fixed in four places.  Not all of these affect Android, but all of them could cause a build failures if anyone ever uses a displayname with a space on some other platform.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #643073 - Flags: review?(ted.mielczarek)
Attachment #643073 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 643073 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 307181

User impact if declined: Can't build Firefox Beta for Android.

Testing completed (on m-c, etc.): Untested

Risk to taking this patch (and alternatives if risky): Very low risk (just fixes some syntax in our build scripts).

String or UUID changes made by this patch: None.
Attachment #643073 - Flags: approval-mozilla-beta?
Attachment #643073 - Flags: approval-mozilla-aurora?
Comment on attachment 643073 [details] [diff] [review]
patch

[Triage Comment]
We need this to land on default as well as MOBILE150_2012071710_RELBRANCH on mozilla-beta
Attachment #643073 - Flags: approval-mozilla-beta?
Attachment #643073 - Flags: approval-mozilla-beta+
Attachment #643073 - Flags: approval-mozilla-aurora?
Attachment #643073 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/7652bd4c0b52
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
You need to log in before you can comment on or make changes to this bug.