Last Comment Bug 774808 - GCLI sometimes stops working
: GCLI sometimes stops working
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 13 Branch
: All All
: P1 normal (vote)
: Firefox 17
Assigned To: Michael Ratcliffe [:miker] [:mratcliffe]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
: 784057 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 12:13 PDT by Dave Camp (:dcamp)
Modified: 2012-08-25 17:05 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (901 bytes, patch)
2012-08-23 06:53 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
fayearthur: review+
Details | Diff | Splinter Review

Description Dave Camp (:dcamp) 2012-07-17 12:13:12 PDT
I'm not sure the exact steps that are leading to this, but once I get in this state the error console spews:

Error: TypeError: this._panel.hidePopup is not a function
Source File: resource:///modules/devtools/DeveloperToolbar.jsm
Line: 680
Comment 1 Kevin Dangoor 2012-08-22 12:30:10 PDT
*** Bug 784057 has been marked as a duplicate of this bug. ***
Comment 2 Kevin Dangoor 2012-08-22 12:33:08 PDT
Bringing mratcliffe across from bug 784057 as the assignee (that bug is a dupe of this one and work had not begun yet)
Comment 3 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-23 06:53:40 PDT
Created attachment 654598 [details] [diff] [review]
Patch

A simple check to see if the node exists before removing it.
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-24 22:57:43 PDT
https://tbpl.mozilla.org/?tree=Fx-Team&rev=bbd267f16fc7
Comment 5 Dave Camp (:dcamp) 2012-08-25 17:05:06 PDT
https://hg.mozilla.org/mozilla-central/rev/bbd267f16fc7

Note You need to log in before you can comment on or make changes to this bug.