Windows task bar no longer auto-hides after nightly update.

VERIFIED WORKSFORME

Status

()

Core
Widget: Win32
VERIFIED WORKSFORME
5 years ago
4 years ago

People

(Reporter: jst, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20130719])

(Reporter)

Description

5 years ago
I have my windows (7) task bar set to auto hide, which generally works fine with nightly builds, something happens in a window, the task bar pops up and shows me what window wants attention etc. Now, if I run a nightly build and restart to apply an update (through the Help->About Nightly dialog) then the nightly quits, the update gets applied, and then nightly starts up again. All good, except, after doing this, the windows task bar no longer auto-hides. Sometimes, but not always, windows shows that there are a set of seemingly random nightly windows that want attention, but even going to all those windows so that no windows want attention any more still doesn't make the task bar auto-hide. The only way to get the task bar to auto-hide again once it's in this state is to quit nightly, and restart manually.

I've seen this randomly for months, but never caught the pattern as to what triggers this, but at this point it's very consistent in its behavior and it seems that there's something in the update process that confuses windows to no longer auto-hide the task bar.

Comment 1

5 years ago
jst reports his main window is not maximized.
Keywords: regressionwindow-wanted

Comment 2

5 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:23.0) Gecko/20130425 Firefox/23.0

I was not able to reproduce this bug, using FF (Build ID:20120701030537), FF (Build ID:20120717030555), FF (Build ID:20130421031002), or FF (Build ID:20130401192816).

Comment 3

4 years ago
Windows 7 64 bit and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130719 Firefox/25.0

I can reproduce the bug: the taskbar hides as soon as I click "Apply" but it shows up again after clicking "Accept" I've tried several times with the same result: it doesn't hide.
Whiteboard: [testday-20130719]
Johnny, have you experienced this recently? If not I suggest we resolve this bug incomplete.
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0
Build ID: 20130722172257
Built from http://hg.mozilla.org/releases/mozilla-beta/rev/8b103274f2d1


User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130725 Firefox/25.0
Build ID: 20130725030212
Built from http://hg.mozilla.org/mozilla-central/rev/a4c1961bf723

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20130725 Firefox/24.0
Build ID: 20130725004004
Built from http://hg.mozilla.org/releases/mozilla-aurora/rev/f61ece780449

Tested on above builds as well as latest nightly, aurora and release using Windows 7.

I don't see this issue.

Are you still seeing issue?
(Reporter)

Comment 6

4 years ago
I don't think I've seen this for quite some time now, closing as worksforme.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Thanks Johnny, marking verified based on comment 5.
Status: RESOLVED → VERIFIED
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.