possible history strangeness; back button disabled

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
VERIFIED WORKSFORME
17 years ago
8 years ago

People

(Reporter: jap3003, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.8.1+) Gecko/20010423
BuildID:    2001042304

I first noticed this on another site, but most recently with Sluggy (the above
URL).  It isn't always reproducible, though.  Basically, after submitting a
madlib, then going back via the back button and resubmitting, my back button
became disabled and never came back.  While going through the recent bugs, I
also noticed that a page or so was missing from the session history as well (it
skipped from about:mozilla (my home page) to the bug search I had started from
the bugzilla.mozilla.org. front page).

Reproducible: Couldn't Reproduce
Steps to Reproduce:
(My best guess:)
1.submit a form
2.go back to the form submission page
3.re-submit

I'm not sure exactly how to reproduce the bug.  It'd be nice if I could just
send a core file.  Alas, I cannot find such functionality.  :)  It seems to
occur just when I'm not expecting it.

Finally, it is local to each individual browser window.  I brought up new
windows, and they were not affected.  I'm also sure it's not just that another
window was popping up, obscuring the other one, since there was no such window,
and since it continued even after I went to other sites.  The window with the
disabled back button is still up and the button not enabled.

Comment 1

17 years ago
On Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1+) Gecko/20010608, using 
back and forth buttons with www.sluggy.com forms, or on any other website 
forms, works as espected, if you push back after summitting, you are back with 
the form fullfilled and the back button activated if you have visitited more 
pages beforo.
Anyway if reporter feels that this is not the case, update mozilla to a current 
trunk nightly and reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 2

17 years ago
I make a mistake marking it as resolved instead of worksforsome
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 3

17 years ago
On Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1+) Gecko/20010608, using 
back and forth buttons with www.sluggy.com forms, or on any other website 
forms, works as espected, if you push back after summitting, you are back with 
the form fullfilled and the back button activated if you have visitited more 
pages beforo.
Anyway if reporter feels that this is not the case, update mozilla to a current 
trunk nightly and reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.