Intermittent assertion during test_bookmark_store.js ("ASSERTION: thread pool wasn't shutdown: '!mPool', file netwerk/base/src/nsStreamTransportService.cpp, line 433")

RESOLVED DUPLICATE of bug 722956

Status

Cloud Services
Firefox Sync: Backend
--
critical
RESOLVED DUPLICATE of bug 722956
6 years ago
6 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({assertion})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Rev3 Fedora 12 fx-team debug test xpcshell on 2012-07-13 11:10:32 PDT for push e7d2e3c6d861

slave: talos-r3-fed-020

https://tbpl.mozilla.org/php/getParsedLog.php?id=13501582&tree=Fx-Team

{
TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | [test_reparentOrphans : 360] io7nzCpfmE4A == io7nzCpfmE4A
Clean up.

TEST-INFO | (xpcshell/head.js) | test 1 finished

TEST-INFO | (xpcshell/head.js) | exiting test

TEST-PASS | (xpcshell/head.js) | 62 (+ 0) check(s) passed

TEST-INFO | (xpcshell/head.js) | 0 check(s) todo
WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../xpcom/base/nsExceptionService.cpp, line 166
###!!! ASSERTION: thread pool wasn't shutdown: '!mPool', file ../../../../netwerk/base/src/nsStreamTransportService.cpp, line 433
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002E6FB3]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002E7042]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002D40BA]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002D4E3E]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002D4E8C]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002D4B19]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x00D1F6D2]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01710EB7]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0171124D]
js::GCForReason(JSRuntime*, js::gcreason::Reason)+0x00000020 [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x016EFD30]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x00CF246A]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0126F61A]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x012728B1]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01272989]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01272B0D]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x012220F5]
NS_ShutdownXPCOM+0x0000001A [/home/cltbld/talos-slave/test/build/firefox/libxpcom.so +0x00001EB6]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/xpcshell +0x000085C8]
__libc_start_main+0x000000E6 [/lib/libc.so.6 +0x00016BB6]
###!!! ASSERTION: thread pool wasn't shutdown: '!mPool', file ../../../../netwerk/base/src/nsStreamTransportService.cpp, line 433
<<<<<<<
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-linux-debug/1342200303/firefox-16.0a1.en-US.linux-i686.crashreporter-symbols.zip
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
}
(Reporter)

Comment 1

6 years ago
Bah, was from before the fix for bug 722956 migrated to fx-team.
No longer blocks: 722956
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 722956
(Reporter)

Updated

6 years ago
No longer blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.