Ctrl-backspace in location bar erases wrong part

RESOLVED DUPLICATE of bug 246237

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 246237
6 years ago
6 years ago

People

(Reporter: Lars Viklund, Unassigned)

Tracking

17 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120718030544

Steps to reproduce:

Type a partial URL in the location bar.
Down-arrow to select one of the suggestions - e.g. http://example.com/~zao/foo.png
Press ctrl-backspace to rub out the last word in the URL.


Actual results:

The last word "png" is selected, not erased, placing the caret between the period and the word.
Subsequent presses of ctrl-backspace erases to the left of the selection, removing "foo.", "zao/", etc.


Expected results:

The last word "png" should have been erased.
The proper behaviour can be observed by pressing ctrl-backspace while typing normally, without having used the suggestion list.

Comment 1

6 years ago
Dup Bug 720284, Bug 246237 ?

Updated

6 years ago
Component: Untriaged → Keyboard: Navigation
Product: Firefox → Core

Comment 2

6 years ago
Bug 777994 is about the same thing.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 246237
You need to log in before you can comment on or make changes to this bug.