Status

()

Core
XPCOM
--
enhancement
RESOLVED DUPLICATE of bug 44675
17 years ago
17 years ago

People

(Reporter: Paul.Sandoz, Assigned: dougt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
It would be useful if XPCOM had an any type that encapsualtes the basic types
and nsISupports such that they can be treated uniformly.

This would great for generic containers like property sets and bags e.g. see the
corba property service:

	ftp://ftp.omg.org/pub/docs/formal/98-10-28.idl

thus there is no need for 'application' specific interfaces with explicit get
and set methods, or attributes (for explicit property names), for types.

Two examples of where this would be useful are the preference and address book
card areas.

It might also make it easier for a Corba<->XPCOM bridge.

Thanks,
Paul.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

17 years ago
This looks to be a dupe of bug 44675
(Assignee)

Comment 2

17 years ago
reassign all kandrot xpcom bug.
Assignee: kandrot → dougt

Comment 3

17 years ago
Yes. This is a dup of bug 44675. I got distracted with other things, but I plan
to have that code in soon. I hope other language mappings will follow my lead
and add their own magic for nsIVariant support with short delay.

This bug also touches on the need for a standard name/value pair collection
feature that I've just filed as bug 98209.


*** This bug has been marked as a duplicate of 44675 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.