TB fails to attach signature image after spending some time in compose window

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: keysuck, Unassigned)

Tracking

14 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 643677 [details]
signature_en.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

I write a long e-mail or spend longer time writing an e-mail.


Actual results:

I hit 'send' and the image in the signature fails to attach to the message while the progress bar is running.


Expected results:

Image in signature should have been attached.
(Reporter)

Comment 1

6 years ago
Created attachment 643679 [details]
image linked to signature HTML
(Reporter)

Updated

6 years ago
Severity: normal → critical

Updated

6 years ago
Severity: critical → major
Whiteboard: [dupeme?]
Severity: major → normal

Comment 2

5 years ago
This works for me using the ESR and current trunk.(Win7 POP3)
However having the name attribute different from the actual filename caused some problems in the "save image" dialog (in my testing)
"save image" resulted in JM-logo rather than the actual filename: JM_logo_en
I imagine this could cause problems somewhere (can't test IMAP auto-save draft here).
(In reply to keysuck from comment #0)
> signature_en.html

<img> tag in HTML signature file.
> <img title="Visit our homepage" style=" ... " alt="JM Instruments Corp."
> src="file:///d:/shared/JM_logo_en.jpg" name="JM-logo">

By Send Later, Save as draft, of HTML mail with the signature file,
Tb 15.0.1 generates following tag(changed to cid: url), 
> <img title="Visit our
>                 homepage" style="border: 0px solid ; width: 200px;
>                 height: 39px;" alt="JM Instruments Corp."
>                 src="cid:part1.07020905.00090700@gmail.com"
>                 name="JM-logo">
and embeds image data in the mail.
> --------------020803050308030401060206
> Content-Type: image/png; name="JM-logo"
> Content-Transfer-Encoding: base64
> Content-ID: <part1.07020905.00090700@gmail.com>
> Content-Disposition: inline; filename="JM-logo"

(A) If image file is deleted/renamed/moved while composing mail before first draft save(manually, or by auto-save) or Send/Send Later, such phenomenon occurs(IIRC, known bug).
(B) If draft is saved while mail composition, and if local Drafts folder(POP3/Local Folders), and if Compact happens after the draft save, and if offset of latest draft mail is changed by Compact, bug 532395 occurs.

Because you say "spend longer time writing an e-mail", drafts save seems to have occurred by auto-save. So, (B) is suspected.

Local Drafts folder? IMAP Drafts folder?
Do you enable auto-save and auto-compact?
Do you enable auto-compact(mail.prompt_purge_threshhold=true) with small mail.purge_threshhold_mb=NNN value, without mail.purge.ask=true?
What message is shown by Tb when you saw following problem?
> the image in the signature fails to attach to the message while the progress bar is running.

Comment 4

5 years ago
Wada,
I never noticed that the original filename was replaced by the "name" attribute before, but it does so even as far back as the current ESR.
BTW you didn't mean image/png did you

Content-Type: image/jpeg;
 name="JM-logo"
Content-Transfer-Encoding: base64
Content-ID: <part1.03030902.08030606@bellatlantic.net>
Content-Disposition: inline;
 filename="JM-logo"
(In reply to Joe Sabash from comment #4)
> BTW you didn't mean image/png did you
> my test   : Content-Type: image/png;  name="JM-logo"
> your test : Content-Type: image/jpeg; name="JM-logo"

I tested with local .png file as image in signature, so image/png was set by Tb in my test. Sorry for confusing test result.

name parameter/filename parameter looks obtained from name attribute of <img>. I also wasn't aware of it until I tested with attached signature file. I don't think it's bad because filename parameter is merely a recommendation of file name when the file is saved by mail recipient, but it may be confusing for some users who send mail using Tb.

Comment 6

3 years ago
So close WFM??
Flags: needinfo?(jsabash)

Comment 7

3 years ago
There are still quirks where autsave/and compact can create problems
But there are always quirks, and genereally this is WFM in current trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jsabash)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.