Clear Private Date Dialog Does not Open in Seamonkey V2.11

RESOLVED INVALID

Status

SeaMonkey
Security
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: FourthDr, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14; Firefox/12.0.0
Build ID: 20110420224920

Steps to reproduce:

Upgraded to Seamonkey 2.11 today from 2.10.1. Launch Seamonkey, selected Tools>Clear Private Date> dialog does not appear. I had to close Seamonkey, then the dialog appears. But only once, then I need to restart Seamonkey again to access the dialog. And again, the dialog will not appear again until Seamonkey is restarted.


Actual results:

Clear Private data dialog not opening unless Seamonkey is restarted. Then only opens once. Another restart is needed to make dial accessible again for another single instance.


Expected results:

The dialog should always come up. I should not have to restart Seamonkey for it to appear.
Do you get the same behavior if you open the dialog and cancel it ?instead of really deleting data ?
Which data do you delete ?
Do you see errors in the error console (Tools/web development/error Console) ?
(Reporter)

Comment 2

6 years ago
Yes. Just opening the ClearPrivateData dialog without deleting anything, the dialog will not return on the second try. But if I restart Seamonkey I can then open the dialog once. It is deleting data by the way. So that at least is working.

I delete all data. But I don't think it matters what data is deleted.

The console returns this error:
Timestamp: 7/18/2012 10:44:36 PM
Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/Sanitizer.jsm :: <TOP_LEVEL> :: line 77"  data: no]

Comment 3

6 years ago
If you restart in Safe Mode, does the problem persist?
(Help | Restart with Addons Disabled)

If that doesn't help, then if you disable Plugins, & also restart in Safe Mode, does the problem persist?
Edit | Preferences | Advanced -> Scripts & Plugins => Enable Plugins for, Suite (uncheck)

If that doesn't help, as a test, create a new clean Profile & see if the problem persists.

Comment 4

6 years ago
Do you have, by any chance, the Session Manager add-on installed?

If so, try manually adding a bool preference 'privacy.item.extensions-sessionmanager' and set it to your linking...
(Reporter)

Comment 5

6 years ago
I have several installations of Seamonkey, all with Session Manager Add-on installed. One installation of Seamonkey 2.11 has the problem, another does not. And a third that has not been updated from 2.10.1 I have found has this problem which I though was limited to 2.11. I did disable the session manager, when I did that the DeletePrivateData dialog then came up every time. So, bug must be with session manager add-on then or with a recently introduce bug in Seamonkey??? I don't recall this being a problem prior to 2.10.
(Reporter)

Comment 6

6 years ago
H. Hofer:

How might I do that? "try manually adding a bool preference 'privacy.item.extensions-sessionmanager'" Would that be in the about:config?
(Reporter)

Comment 7

6 years ago
H. Hofer:

Adding 'privacy.item.extensions-sessionmanager' to the about:config solved the DeletePrivateData dialog not appearing problem. Tried it several times and restarted Seamonkey several times. So why did that work? What's at fault here?

Comment 8

6 years ago
So, no problem with SeaMonkey, but with add-on, closing then, please, report about your issue to add-on author
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.