Hook up Java console streams on Mac

RESOLVED WONTFIX

Status

Core Graveyard
Java: Live Connect
RESOLVED WONTFIX
18 years ago
8 years ago

People

(Reporter: Patrick C. Beard, Assigned: Patrick C. Beard)

Tracking

Trunk
Future
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
When running the LiveConnect or XPConnect with LiveConnect turned on shells, 
calls to System.out/err/in don't hook to the console window. This simple patch to 
jsj_simpleapi.c fixes that.
(Assignee)

Comment 1

18 years ago
Created attachment 32164 [details] [diff] [review]
Use MRJ specific API to hook up Java console.
(Assignee)

Comment 2

17 years ago
Taking this bug, since I wrote the patch.
Assignee: rogerl → beard

Comment 3

17 years ago
*** Bug 92884 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

17 years ago
This is for the standalone version of LiveConnect.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

15 years ago
Patrick, can we close this bug, or is it still valid for Mac OS X ?

Comment 6

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 7

14 years ago
Comment on attachment 32164 [details] [diff] [review]
Use MRJ specific API to hook up Java console.

Brendan and Kyle, this patch is over three years old and the file has only been
touched for licensing issues since. Do we still need this stuff (and is the
patch ok?) or is this patch and the corresponding bug obsolete (since we no
longer support the classic Mac)?
Attachment #32164 - Flags: superreview?(brendan)
Attachment #32164 - Flags: review?(kyle.yuan)

Comment 8

14 years ago
Comment on attachment 32164 [details] [diff] [review]
Use MRJ specific API to hook up Java console.

jsj_simpleapi.c is no longer in the makefile.
Attachment #32164 - Flags: review?(kyle.yuan) → review-

Comment 9

14 years ago
Marking WONTFIX per Kyle Yuan's comment.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Updated

14 years ago
Attachment #32164 - Flags: superreview?(brendan)

Updated

8 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.