images missing on linux build

VERIFIED FIXED

Status

()

Core
ImageLib
--
major
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Scott Kester, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib] critical for mozilla 0.9.1, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; rv:0.8.1+)
Gecko/20010425
BuildID:    2001042506

Some images are not displayed on linux builds. On the URL above there should be
a row of 'tab images' above the 'Your Local Outlook' section. These images are
usally missing, but can be made to display (sometimes partially) by scrolling
the page down, and back up, or by covering the browser with another window.
Using 'CTRL reload' does not make any difference, so I don't think it is a cache
issue. Other images such as the 'go' button on the 'enter city or zip' form
never display.  The same days windows build does not have this problem.  Looks
like a libpr0n issue, or perhaps viewmanager.

Reproducible: Always
Steps to Reproduce:
1.go to www.weather.com
2.look for tab images, or 'go' button on form.
3. scroll the page up and down and the images will usually render at least partially

Actual Results:  Images that display on windows builds are missing on linux builds.

Expected Results:  images should display.

I think this started when libpr0n landed, and it is not a scaling issue (bug
74313) as that has been fixed, and the problem still exists.

Comment 1

17 years ago
I see this too on a linux build today.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
changing status to [imglib]
Whiteboard: [imglib]

Updated

17 years ago
Whiteboard: [imglib] → [imglib] critical for mozilla 0.9.1
(Assignee)

Updated

17 years ago
Depends on: 74129

Comment 3

17 years ago
*** Bug 79335 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
*** Bug 79402 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Trying an image intensive site (www.rankpeople.com), many images load with blue
sections for some reason, the blue goes away if you click on the image (even if
it's not a link)... on weather.com, it uses white instead of blue, I believe.

Comment 6

17 years ago
Possible dupe of 73972?

Comment 7

17 years ago
73972 might be related to this but I don't think this is a duplicate of that
(it's the other way around, if anything).  I'm experiencing this phenomenon with
JPEG and PNG images as well, under 0.9.  Images randomly load in a completely or
partially invisible state, and randomly change their state when moused over or
when text is selected near them (sometimes reverting to their alt text only
state, sometimes just completely disappearing never to be seen again).  I also
have image form buttons that refuse to show up under any circumstances, until
they are clicked, and then they suddenly appear.

I would have to wager it's the new image library, because .81 did nothing this
bizarre with images.
(Assignee)

Comment 8

17 years ago
i need to test this with my latest changes
Keywords: qawanted
(Reporter)

Comment 9

17 years ago
Stuart,

I have been testing your fix with build 2001051521.  Unfortunetly
www.weather.com has changed their page layout, and the images that I reported
the problem on are gone.  However the other pages I remember having missing
images are now rendered correctly.  Based on that I am marking this as FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Just adding a verification, this with 2001051608.  Every page I had issue with
is displaying properly on load now, and nothing bizarre happens with mouseovers,
etc.

Comment 11

17 years ago
Verified fixed linux build 2001051706
Verified fixed mac build 2001051705
Verified fixed w98 build 2001051604
Status: RESOLVED → VERIFIED

Comment 12

17 years ago
*** Bug 80267 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.