Last Comment Bug 775453 - report-a-bug popup div on youtube does not redraw
: report-a-bug popup div on youtube does not redraw
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: 16 Branch
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Chris Lord [:cwiiis]
: Paul Silaghi, QA [:pauly]
Mentors:
Depends on:
Blocks: 758620
  Show dependency treegraph
 
Reported: 2012-07-19 03:01 PDT by Lars Viklund
Modified: 2012-10-12 07:05 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified


Attachments

Description Lars Viklund 2012-07-19 03:01:56 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120718030544

Steps to reproduce:

Trying to repro a previously reported bug (754600), I went to http://youtube.com, scrolled to the bottom, clicked on the "Report a bug" link.


Actual results:

A div opens, which asks the user to type in a brief description of the issue.
When typing into it, it does not redraw, nor does the focus on the text area update.

You must drag the window for any updates to redraw, upon which it displays the blindly typed text.


Expected results:

The UI should update whenever typing in it.
Comment 1 Loic 2012-07-19 07:02:33 PDT
It's a recent regression.

Mozregression range:

m-c
good=2012-06-27
bad=2012-06-28
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5cdbeae14405&tochange=bf8f2961d0cc

m-i
good=2012-06-27
bad=2012-06-28
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2791940fb1ff&tochange=dcf8693ba5e1

Suspected bug to confirm:

Ehsan Akhgari — Bug 766843 - Exempt inner table frames from optimized dynamic position change handling, as the required handling is performed for outer table frames; r=bzbarsky
Comment 2 Alice0775 White 2012-07-19 07:27:29 PDT
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/06e7df3a8209
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120627083614
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7ef9568fbd40
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120627084814
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=06e7df3a8209&tochange=7ef9568fbd40

Triggered by:Bug 758620
Comment 3 Loic 2012-07-19 07:55:32 PDT
I thought to this bug too but as it is flagged for ARM plateform even if it's in trunk, I didn't retain it. :[
Anyway thanks for the confirmation.
Comment 4 Chris Lord [:cwiiis] 2012-07-23 15:27:26 PDT
I expect this is triggered by the same problem as is fixed in bug 769541. I'll be able to push that soon hopefully, and assuming it lands, we can re-test this.
Comment 5 Chris Lord [:cwiiis] 2012-08-07 05:48:03 PDT
I can't reproduce this on Nightly or Aurora on Windows, marking this as fixed (see comment #4).
Comment 6 Paul Silaghi, QA [:pauly] 2012-09-19 07:22:53 PDT
Saw the issue on nightly 2012-07-19.
Verified fixed on FF 16b3 on Win 7 x64, Ubuntu 12.04 and Mac OS X 10.7.4.
Comment 7 Paul Silaghi, QA [:pauly] 2012-09-19 07:49:00 PDT
Found another related issue with this occasion - bug 792422.
Comment 8 Paul Silaghi, QA [:pauly] 2012-10-12 07:05:24 PDT
Verified fixed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0b1

Note You need to log in before you can comment on or make changes to this bug.