Possible problem with omni.ja

RESOLVED DUPLICATE of bug 605524

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 605524
5 years ago
5 years ago

People

(Reporter: andrew, Unassigned)

Tracking

14 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
omni.ja as shipped in firefox 14.0.1 (official linux x86 binary) seems to have changed format or was somehow corrupted.

7z t omni.ja gives "Error: Can not open file as archive" whereas on 13.0.1's omni.ja the same command yields "Everything is Ok".

file(1) reports omni.ja from 14.0.1 to be of type "ACB archive data" instead of "Zip archive data, at least v1.0 to extract" as with the prior FF release.

Has the format changed or is the file damaged? Thanks.
that file is NOT a common zip file, there is an internal optimization and you can't just decompress and recompress it with utils like 7-zip.
That said the only thing that may have changed is that the optimization was broken and fixed in bug 726656, though according to the bug itself the format should have changed back to be optimized in Firefox 13, maybe you recompressed the file and the upgrade to FF14 just replaced it again?
This was bug 772841, where we broke jar optimization *again*, actually.

As Marco says, omni.ja is a highly optimized zip file, so many zip utilities cannot read it. This is known and expected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 605524
(Reporter)

Comment 4

5 years ago
Hi thanks for your answer. I understand these omni files are optimized internally for loading performance issues. However, the envelope compression up through 13.0.1 was zip and was recognized, as such, by different Linux utilities.

As of 14.0.1, several utilities have issues decompressing and/or recognizing the file type.

I am not working on my own files here, rather testing officially bundled omni.ja files from official Mozilla releases (firefox-13.0.1.tar.bz2 and firefox-14.0.1.tar.bz2).
Right, it's simply a bug that we stopped optimizing the file for a few releases. It's still a valid (AFAIK) zip file, it's just a bit different from what most zip utilities expect.
You need to log in before you can comment on or make changes to this bug.