Closed Bug 775630 Opened 10 years ago Closed 10 years ago

Swipe on content area while the tab menu is open should not pan content

Categories

(Firefox for Android Graveyard :: General, defect)

15 Branch
All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 766858

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

(Keywords: polish, Whiteboard: [patch in bug 766858])

Steps to reproduce:
1. In the phone UI, load a web page.
2. Open the tabs tray.
3. Tap in the content area to close the tabs tray.
4. While the tab tray is sliding closed, swipe upward slightly.

Expected results: Tab tray closes and content does not scroll.
Actual results: Content is scrolled up or down.

Bug 763726 added this gesture to close the tab tray.  The code from bug 763726 hides DOWN events from content, but it does not suppress MOVE events.
There's a patch that fixes this in bug 766858.
tracking-fennec: ? → ---
Depends on: 766858
Whiteboard: [patch in bug 766858]
Fixed by the patch in bug 766858.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766858
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.