Last Comment Bug 775661 - [AccessFu] Add dump tree and accessible states methods to logger
: [AccessFu] Add dump tree and accessible states methods to logger
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla17
Assigned To: Eitan Isaacson [:eeejay]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 10:59 PDT by Eitan Isaacson [:eeejay]
Modified: 2012-07-20 21:05 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Added dump tree Logger method, and states to string function. (1.63 KB, patch)
2012-07-19 11:00 PDT, Eitan Isaacson [:eeejay]
dbolter: review+
Details | Diff | Splinter Review

Description Eitan Isaacson [:eeejay] 2012-07-19 10:59:13 PDT

    
Comment 1 Eitan Isaacson [:eeejay] 2012-07-19 11:00:09 PDT
Created attachment 643935 [details] [diff] [review]
Added dump tree Logger method, and states to string function.
Comment 2 David Bolter [:davidb] 2012-07-19 11:47:25 PDT
Comment on attachment 643935 [details] [diff] [review]
Added dump tree Logger method, and states to string function.

Review of attachment 643935 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/src/jsat/Utils.jsm
@@ +168,5 @@
> +  },
> +
> +  statesToString: function statesToString(aAccessible) {
> +    let [state, extState] = Utils.getStates(aAccessible);
> +    let statesArray = [];

I'd probably call it stringArray, or strings, but not stingRay because that would be silly.
Comment 3 Eitan Isaacson [:eeejay] 2012-07-20 09:48:00 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/69a69e2a873d
Comment 4 Eitan Isaacson [:eeejay] 2012-07-20 09:51:23 PDT
(In reply to David Bolter [:davidb] from comment #2)
> Comment on attachment 643935 [details] [diff] [review]
> Added dump tree Logger method, and states to string function.
> 
> Review of attachment 643935 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: accessible/src/jsat/Utils.jsm
> @@ +168,5 @@
> > +  },
> > +
> > +  statesToString: function statesToString(aAccessible) {
> > +    let [state, extState] = Utils.getStates(aAccessible);
> > +    let statesArray = [];
> 
> I'd probably call it stringArray, or strings, but not stingRay because that
> would be silly.

LOL. Changed.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-20 21:05:22 PDT
https://hg.mozilla.org/mozilla-central/rev/69a69e2a873d

Note You need to log in before you can comment on or make changes to this bug.