Autophone - Gradual S1/S2 regression in "throbber start" time

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
4 years ago

People

(Reporter: gbrown, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
A 60-day view of Local Twitter Page / Time to Throbber Start on http://mrcote.info/phonedash/#/rawfennecstartup shows a gradual increase. The increase looks nearly linear, with greater slope for the Nexus S phones than for the GS2. (There is no such increase for the Time to Throbber Stop.)

Such a constant increment over a long period seems odd -- is there a fault in the test framework? Is something accumulating in the profiles??

Comment 2

6 years ago
I'm not positive about this. At the moment, the framework does not reboot the phone before or after each test. I think that, perhaps, the Nexus S phones have some bug that slowly decreases performance over time. The Galaxy S2 doesn't seem affected by this. I will add a reboot before each test to see if that smooths out the line.

Comment 3

6 years ago
I am running yet another batch over the same time period (June 3 to now) but rebooting the phone before the test run. Results will be available at http://mrcote.info:8119/.
in addition to rebooting, are you running with a clean profile each time?

Comment 5

6 years ago
Yup, new profile every time.

So now with reboots, there still appears to be a gradual increase in throbberstart time. Although this time it looks more like a few increases until June 17, then a levelling out. Note that throbberstop does not show this increase.

Comment 6

6 years ago
So we're pretty sure we know about the throbberstart regression in mid June, and it looks like there is no real regression after that.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Updated

4 years ago
Blocks: 953342
Summary: Gradual S1/S2 regression in "throbber start" time → Autophone - Gradual S1/S2 regression in "throbber start" time
You need to log in before you can comment on or make changes to this bug.