Closed Bug 775723 Opened 9 years ago Closed 9 years ago

Native handles shrink when dragged to the right/bottom of the content area

Categories

(Firefox for Android Graveyard :: Text Selection, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox15 verified, firefox16 verified, firefox17 verified)

VERIFIED FIXED
Firefox 17
Tracking Status
firefox15 --- verified
firefox16 --- verified
firefox17 --- verified

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(1 file)

This is something Android is doing with the ImageViews that we're using. It would be ideal if there was a way to let them overflow gecko_layout so that they just get cut off (this currently works when dragging to the left/top of the content area).
Attached patch patchSplinter Review
This fixes the issue by adding negative right/bottom margin to the handles.
Assignee: nobody → margaret.leibovic
Attachment #644045 - Flags: review?(mark.finkle)
Attachment #644045 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/8ac4a4902afe
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Comment on attachment 644045 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 774938 (native text selection handles)
User impact if declined: handles shrink when dragged to the edge of the screen
Testing completed (on m-c, etc.): landed on m-c 7/20
Risk to taking this patch (and alternatives if risky): low-risk style change
String or UUID changes made by this patch: n/a
Attachment #644045 - Flags: approval-mozilla-beta?
Attachment #644045 - Flags: approval-mozilla-aurora?
Comment on attachment 644045 [details] [diff] [review]
patch

approved for beta/aurora as part of the dep bugs for native handles for text selection.
Attachment #644045 - Flags: approval-mozilla-beta?
Attachment #644045 - Flags: approval-mozilla-beta+
Attachment #644045 - Flags: approval-mozilla-aurora?
Attachment #644045 - Flags: approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.