Last Comment Bug 775763 - CSS3 transform broken in Firefox 14
: CSS3 transform broken in Firefox 14
Status: RESOLVED DUPLICATE of bug 747637
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 14 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 734953
  Show dependency treegraph
 
Reported: 2012-07-19 15:53 PDT by Steve Kwan
Modified: 2012-07-30 10:33 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Steve Kwan 2012-07-19 15:53:45 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

We use CSS3 transforms extensively on our site, particularly in our top nav:
http://www.easports.com/madden-nfl

Upon updating to Firefox 14, the transforms (rotation, skew) no longer work.  They continue to work in Chrome, Safari and older versions of Firefox.


Actual results:

Attempting to use any form of CSS3 transforms appears not to work.  This is also reproducible by trying to create a CSS3 transform using the CSS3 Generator site:
http://css3generator.com/


Expected results:

CSS3 transforms should continue to work as in previous versions of Firefox.
Comment 1 Loic 2012-07-19 16:40:33 PDT
skew() has been removed from Firefox, use skewX() & skewY() instead.
See bug 734953.
Comment 2 Steve Kwan 2012-07-19 17:00:09 PDT
According to css3generator.com, skew has been supported since Firefox 3.5.  It continues to be supported in other major browsers.

I understand that skew has been removed from CSS3 and that its purpose can be misleading, but it is a feature used by a massive portion of the web.  css3generator.com itself uses skew in its examples.

As CSS3 is still in flux, it seems like a massive mistake to arbitrarily remove features that are widely used.
Comment 3 j.j. 2012-07-20 03:22:13 PDT
Using experimental features results in experimental experience!

(In reply to Steve Kwan from comment #2)
> As CSS3 is still in flux, it seems like a massive mistake to arbitrarily
> remove features that are widely used.

No, there is no flux. The W3C CSS standard is finished now in regard to features and syntax. All browser vendors agree on this.
IE 10 will ship this without prefix.
Old/non-standard syntax may be supported by other browsers only with prefix, e.g. -webkit-.

(It's WebKit's policy not to change shipped pefixed properties, which causes lots of problems. Mozilla's policy is different for good reasons.)
Comment 4 Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-07-30 05:04:59 PDT
We've decided we're going to restore skew() support.

*** This bug has been marked as a duplicate of bug 747637 ***
Comment 5 Steve Kwan 2012-07-30 10:33:08 PDT
Definitely a good decision.  Thanks so much for your consideration - the backwards compatibility is definitely appreciated!

Note You need to log in before you can comment on or make changes to this bug.