Firefox doesn't play video on Flash or h264 video hosting sites if Flash plugin is not installed

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Pavlos Touboulidis, Unassigned)

Tracking

17 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120718030544

Steps to reproduce:

I opened Firefox, went to Youtube and clicked on a featured video.
I went on Vimeo and tried to watch a video.
Last, I tried on Dailymotion.


Actual results:

On Youtube, all I could see was a black box that said "This video is currently unavailable."

On Vimeo, I saw a larger black box that said:
"Boo-hoo!This video can’t be played with your current setup. Please switch to a browser that provides native H.264 support or install Adobe Flash Player."

On Dailymotion, it said:
"You need to upgrade your Adobe Flash Player to watch this video.
Download it from Adobe"


Expected results:

I would have expected Firefox to play the videos.

WHY NOT PLAY?
Is the flash plugin listed in about:plugins ?
(Reporter)

Comment 2

6 years ago
(In reply to Matthias Versen (Matti) from comment #1)
> Is the flash plugin listed in about:plugins ?
"No enabled plugins found"

Thank you for your reply. I submitted this bug because I believe the problem mentioned shows that the Mozilla Mission is in danger. It seems the web is incompatible with the available free browsers.

Comment 3

6 years ago
Well, obviously if a website requires Flash and you don't have it installed, the website ain't going to work. :)

Are you making the point that Firefox should support Flash natively or bundle it with the browser in the same way that Google does with Chrome?
(Reporter)

Comment 4

6 years ago
I have no idea what Firefox should do! It seems Mozilla's stuck between a rock and a hard place. Bundle Flash? Support h264 on the desktop? Convince Google to deliver on it's promise to support HTML video and drop Flash (lol)? Some other crazy idea, like bundling the MP4 Youtube Downloader add-on [1] ? Or maybe add DRM support and built-in ads to HTML5?


What's the plan?



[1] https://addons.mozilla.org/en-US/firefox/addon/mp4-downloader/

Updated

6 years ago
Summary: Firefox doesn't work on video hosting sites → Firefox doesn't play video on Flash video hosting sites if Flash plugin is not installed
Firefox doesn't bundle Flash right now.  Flash is part of the plugin container that runs in a separate process from Firefox.  The reason is that if any plugins crash, it will not bring down Firefox as well.  

You can go to this link to download the latest Flash plugin:
http://download.macromedia.com/get/flashplayer/current/licensing/win/install_flash_player_11_plugin.exe
(Reporter)

Updated

6 years ago
Summary: Firefox doesn't play video on Flash video hosting sites if Flash plugin is not installed → Firefox doesn't play video on Flash or h264 video hosting sites if Flash plugin is not installed
The reported issue is not a bug and we a only managing real bugs for our developers.
That is the only reason why bugzilla exists here.
The website requires a plugin (in this case flash) and you don't have it installed (as it seems). You can only install flash or don't use the page.
Bundling non free Software is no option for Mozilla and mp4 in html5 isn't supported except on mobile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.