[traceback] root OperationalError: (1054, "Unknown column 'users_install.client_data_id' in 'on clause'")

RESOLVED DUPLICATE of bug 775926

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 775926
7 years ago
7 years ago

People

(Reporter: cvan, Assigned: kngo)

Tracking

2012-07-26
Dependency tree / graph

Details

()

http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/1644/



OperationalError: (1054, "Unknown column 'users_install.client_data_id' in 'on clause'")

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "addons/decorators.py", line 32, in wrapper
    return f(request, addon, *args, **kw)

  File "amo/decorators.py", line 29, in wrapper
    return func(request, *args, **kw)

  File "amo/decorators.py", line 95, in wrapper
    return f(request, *args, **kw)

  File "addons/decorators.py", line 71, in wrapper
    return f(request, addon, *args, **kw)

  File "mkt/ratings/views.py", line 132, in add
    if install_w_user_agent:

  File "django/db/models/query.py", line 113, in __nonzero__
    iter(self).next()

  File "django/db/models/query.py", line 107, in _result_iter
    self._fill_cache()

  File "django/db/models/query.py", line 784, in _fill_cache
    self._result_cache.append(self._iter.next())

  File "caching/base.py", line 103, in __iter__
    obj = iterator.next()

  File "caching/base.py", line 159, in fetch_by_id
    pks = [val[0] for val in vals]

  File "django/db/models/query.py", line 107, in _result_iter
    self._fill_cache()

  File "django/db/models/query.py", line 784, in _fill_cache
    self._result_cache.append(self._iter.next())

  File "django/db/models/query.py", line 971, in iterator
    for row in self.query.get_compiler(self.db).results_iter():

  File "django/db/models/sql/compiler.py", line 695, in results_iter
    for rows in self.execute_sql(MULTI):

  File "django/db/models/sql/compiler.py", line 750, in execute_sql
    cursor.execute(sql, params)

  File "django/db/backends/mysql/base.py", line 86, in execute
    return self.cursor.execute(query, args)

  File "MySQLdb/cursors.py", line 173, in execute
    self.errorhandler(self, exc, value)

  File "MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
Assignee

Comment 1

7 years ago
https://github.com/mozilla/zamboni/commit/24903c76b726e41eac2ea78cb60b101ea3515e5d
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
I should've duped bug 775926 - because I totally filed this first. But I'll forward dupe this one.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 775926
You need to log in before you can comment on or make changes to this bug.