crash in nsHttpChannel::GetProfileDirectory

RESOLVED DUPLICATE of bug 761946

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 761946
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

15 Branch
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
It's currently #20 top browser crasher in 15.0b1 and first appeared in 15.0a2/20120711. The regression range might be:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=23c1df05027f&tochange=99faf1860ca5

One comment says: "Tried to use Cocoon plugin and pop - dies!"

Signature 	nsHttpChannel::GetProfileDirectory(nsILocalFile**) More Reports Search
UUID	b1c3bd18-4833-4909-968d-9d5b22120720
Date Processed	2012-07-20 07:16:40
Uptime	47
Last Crash	3.9 minutes before submission
Install Age	4.9 minutes since version was first installed.
Install Time	2012-07-20 07:11:43
Product	Firefox
Version	15.0
Build ID	20120717110313
Release Channel	beta
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 37 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x9552, AdapterSubsysID: 04341028, AdapterDriverVersion: 8.821.0.0
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
Processor Notes 	This dump is too long and has triggered the automatic truncation routine
EMCheckCompatibility	True
Adapter Vendor ID	0x1002
Adapter Device ID	0x9552
Total Virtual Memory	4294836224
Available Virtual Memory	3681181696
System Memory Use Percentage	39
Available Page File	3661983744
Available Physical Memory	3809918976

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsHttpChannel::GetProfileDirectory 	netwerk/protocol/http/nsHttpChannel.cpp:4927
1 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:70
2 	xul.dll 	XPCWrappedNative::GetAttribute 	js/xpconnect/src/xpcprivate.h:2754
3 	xul.dll 	XPC_WN_GetterSetter 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1548
4 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:313
5 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:361
6 	mozjs.dll 	JSObject::getGeneric 	js/src/jsobjinlines.h:162
7 	mozjs.dll 	JSObject::getGeneric 	js/src/jsobjinlines.h:177
8 	mozjs.dll 	JSObject::getProperty 	js/src/jsobjinlines.h:183
9 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2440
10 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:329
11 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:361
12 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5515
13 	xul.dll 	nsXPCWrappedJSClass::CallQueryInterfaceOnJSObject 	js/xpconnect/src/XPCWrappedJSClass.cpp:263
14 	xul.dll 	nsXPCWrappedJSClass::DelegatedQueryInterface 	js/xpconnect/src/XPCWrappedJSClass.cpp:717
15 	xul.dll 	nsXPCWrappedJS::QueryInterface 	js/xpconnect/src/XPCWrappedJS.cpp:128
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsHttpChannel%3A%3AGetProfileDirectory%28nsILocalFile**%29
(Reporter)

Comment 1

6 years ago
More reports also at:
https://crash-stats.mozilla.com/report/list?signature=nsHttpChannel%3A%3AGetProfileDirectory
Crash Signature: [@ nsHttpChannel::GetProfileDirectory(nsILocalFile**)] → [@ nsHttpChannel::GetProfileDirectory(nsILocalFile**)] [@ nsHttpChannel::GetProfileDirectory]
OS: Windows 7 → All
Hardware: x86 → All
Could this be a dup of bug 761946?
(Reporter)

Comment 3

6 years ago
(In reply to Honza Bambas (:mayhemer) from comment #2)
> Could this be a dup of bug 761946?
Yes because it's also correlated to Cocoon.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 761946
You need to log in before you can comment on or make changes to this bug.