The captcha for submitting demos is not working

RESOLVED WONTFIX

Status

developer.mozilla.org
Demo Studio / Dev Derby
--
major
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: Inkbug, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
I logged in to the new kuma site (https://developer-new.mozilla.org/), and found that my demo was not there, so I tried to re-upload it (at https://developer-new.mozilla.org/en-US/demos/submit), but the captcha was not there (instead it said Input error: Invalid referer), and one couldn't submit the demo without the captcha.
(Reporter)

Comment 1

6 years ago
BTW, the demo (one the old site) is here: https://developer.mozilla.org/en-US/demosdetail/fade-painter
Thanks for the bug report Inkbug!

I see we're using Google for the CAPTCHA service, and since our beta is hosted on developer-new.mozilla.org instead of developer.mozilla.org, I'm guessing it doesn't like that hostname.

I'll see who I can get in touch with to add developer-new as an acceptable referrer.

David
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hey Inkbug! Thanks for submitting the awesome demo. I really enjoyed playing around with it.

The Kuma website (developer-new) is just in beta for now. Before we officially launch, we will be sure to migrate all new demos over (see bug 773381). So don't worry, your demo will always be available on our official website.

I am going to mark this as "WONTFIX" -- don't mind the aggressive word (it's just what Bugzilla uses), it just means that there is not much need to fix the CAPTCHA if it will be automatically start working when we launch, anyway.

Thanks again!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

6 years ago
Thanks so much!
(Assignee)

Updated

6 years ago
Version: Kuma → unspecified
(Assignee)

Updated

6 years ago
Component: Demos → Demo Studio / Dev Derby
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.