Closed Bug 775918 Opened 8 years ago Closed 2 years ago

[mk] review plural rule for Macedonian

Categories

(Mozilla Localizations :: mk / Macedonian, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1415906

People

(Reporter: Pike, Unassigned)

Details

I just came across a change in intl.properties for mk, switching from rule 1 to 15.

I can't figure out why we added rule 14 added in bug 413670 for mk, Kevin, do you remember?

https://developer.mozilla.org/en/Localization_and_Plurals#Plural_rule_.2314_%283_forms%29 claims to be mk, I'm filled with doubt from what I found on the tubes.
Hi Axel, I originally filed 413670 for Irish only - no idea where rule 14 came from.  

You probably looked at the same places I usually do, but rule 15 appears to be the most popular choice on the tubes, e.g. in Launchpad:

https://translations.launchpad.net/+languages/mk

and CLDR:

http://unicode.org/repos/cldr-tmp/trunk/diff/supplemental/language_plural_rules.html

Pootle differs only regarding how to handle "11" (and the odd redundancy in the way the rule is written leads me to believe it's a bug?):
http://translate.sourceforge.net/wiki/l10n/pluralforms
Pootle has it wrong as I see, "11" should be plural.
As far as I have it this is the correct plurals = n%10==1 ? n%100==11 ? 1 : 0 : 1;
As confusing as this might be, duping against a more recent bug.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1415906
You need to log in before you can comment on or make changes to this bug.