Closed Bug 775928 Opened 7 years ago Closed 7 years ago

Intermittent PEP TEST-UNEXPECTED-FAIL | test_contextMenu.js | fail threshold: 0.0 < metric: 2.916 , followed by: test_openBookmarksMenu.js | fail threshold: 0.0 < metric: 26.098

Categories

(Testing Graveyard :: Peptest, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [red])

Rev3 Fedora 12 mozilla-inbound pgo test peptest on 2012-07-19 19:19:10 PDT for push 9ebf591bb011

slave: talos-r3-fed-004

https://tbpl.mozilla.org/php/getParsedLog.php?id=13691658&tree=Mozilla-Inbound

{
19:21:45     INFO - #####
19:21:45     INFO - ##### Running run-peptest step.
19:21:45     INFO - #####
19:21:45     INFO - Running command: ['/home/cltbld/talos-slave/test/build/venv/bin/python', '-u', '/home/cltbld/talos-slave/test/build/tests/peptest/peptest/runpeptests.py', '--app', 'firefox', '--binary', '/home/cltbld/talos-slave/test/build/application/firefox/firefox', '--test-path', '/home/cltbld/talos-slave/test/build/tests/peptest/tests/firefox/firefox_all.ini', '--timeout', '60', '--tracer-threshold', '50', '--tracer-interval', '10', '--proxy', '/home/cltbld/talos-slave/test/build/tests/peptest/tests/firefox/server-locations.txt', '--proxy-host-dirs', '--server-path', '/home/cltbld/talos-slave/test/build/tests/peptest/tests/firefox/server', '--log-level', 'INFO', '--iterations', '10']
19:22:15     INFO -  PEP TEST-START | test_contextMenu.js
19:22:15  WARNING -  PEP WARNING    | test_contextMenu.js | content_reload | unresponsive time: 54 ms
19:22:15    ERROR -  PEP TEST-UNEXPECTED-FAIL | test_contextMenu.js | fail threshold: 0.0 < metric: 2.916
19:22:15     INFO -  PEP TEST-END   | test_contextMenu.js | finished in: 2769 ms
19:22:15     INFO -  PEP TEST-START | test_openBlankTab.js
19:22:15     INFO -  PEP TEST-PASS  | test_openBlankTab.js | fail threshold: 0.0 >= metric: 0
19:22:15     INFO -  PEP TEST-END   | test_openBlankTab.js | finished in: 547 ms
19:22:15     INFO -  PEP TEST-START | test_openBookmarksMenu.js
19:22:15  WARNING -  PEP WARNING    | MOZMILL fail {"message":"[JavaScript Warning: \"Error: Failed to preserve wrapper of wrapped native weak map key.\" {file: \"chrome://browser/content/places/browserPlacesViews.js\" line: 72}]"}
19:22:15  WARNING -  PEP WARNING    | MOZMILL fail {"message":"[JavaScript Warning: \"Error: Failed to preserve wrapper of wrapped native weak map key.\" {file: \"chrome://browser/content/places/browserPlacesViews.js\" line: 328}]"}
19:22:15  WARNING -  PEP WARNING    | MOZMILL fail {"message":"[JavaScript Warning: \"Error: Failed to preserve wrapper of wrapped native weak map key.\" {file: \"chrome://browser/content/places/browserPlacesViews.js\" line: 328}]"}
19:22:15  WARNING -  PEP WARNING    | MOZMILL fail {"message":"[JavaScript Warning: \"Error: Failed to preserve wrapper of wrapped native weak map key.\" {file: \"chrome://browser/content/places/browserPlacesViews.js\" line: 342}]"}
19:22:15  WARNING -  PEP WARNING    | MOZMILL fail {"message":"[JavaScript Warning: \"Error: Failed to preserve wrapper of wrapped native weak map key.\" {file: \"chrome://browser/content/places/browserPlacesViews.js\" line: 328}]"}
19:22:15  WARNING -  PEP WARNING    | test_openBookmarksMenu.js | show_all_bookmarks | unresponsive time: 147 ms
19:22:15  WARNING -  PEP WARNING    | MOZMILL fail {"message":"[JavaScript Error: \"TelemetryStopwatch: key \"FX_SESSION_RESTORE_COLLECT_DATA_MS\" was already initialized\" {file: \"resource://gre/modules/TelemetryStopwatch.jsm\" line: 53}]"}
19:22:15  WARNING -  PEP WARNING    | test_openBookmarksMenu.js | show_all_bookmarks | unresponsive time: 67 ms
19:22:15    ERROR -  PEP TEST-UNEXPECTED-FAIL | test_openBookmarksMenu.js | fail threshold: 0.0 < metric: 26.098
19:22:15     INFO -  PEP TEST-END   | test_openBookmarksMenu.js | finished in: 728 ms
19:22:15  WARNING -  PEP WARNING    | MOZMILL fail {"message":"[JavaScript Error: \"no element found\" {file: \"chrome://browser/content/places/editBookmarkOverlay.xul\" line: 1}]"}
}
Whiteboard: [orange] → [orange][red]
Peptest was made perma-green due to the nature of the framework. Awhile back mcote and the snappy team figured that it would be more useful as a comparison tool to chart the responsiveness over time rather than as a hard regression tool. These failures don't really mean much as a result, though they are left in for now until we figure out exactly how peptest is going to get used going forward.

This didn't actually turn up orange, did it?
It showed up as red, I just have to put [orange] into the whiteboard (as well) due to the way TBPL does its searches.
Weird.. here is the relevant logs: http://pastebin.mozilla.org/1709429
It looks like it starts with "[JavaScript Error: \"no element found\" {file: \"chrome://browser/content/places/editBookmarkOverlay.xul\" line: 1}]"

Then there are bunch of "window is null" and "Method with name: 'OpenBrowserWindow' is not in any open window" errors.

The first two tests ran fine, so maybe there was a crash (though peptest should handle that).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange][red] → [red]
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.