Cannot open include file: 'audio_coding_module_typedefs.h': No such file or directory

RESOLVED FIXED in mozilla24

Status

()

Core
WebRTC
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Sergey, Assigned: hATrayflood)

Tracking

Trunk
mozilla24
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC], [blocking-webrtc-] [qa-])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Tried to build latest mozilla-central (rev 99767 on branch "default") using MSVC 10.0


Actual results:

Compilation stopped at this:

../../../../../../../media/webrtc/trunk/src/video_engine/..\modules/utility/interface/file_recorder.h(14) : fatal error C1083: Cannot open include file: 'audio_coding_module_typedefs.h': No such file or directory
(Reporter)

Comment 1

5 years ago
Another error:

z:\programming\thirdpartysources\mozilla-central\media\webrtc\trunk\src\voice_engine\main\source\channel.h(15) : fatal error C1083: Cannot open include file: 'audio_conference_mixer_defines.h': No such file or directory
Component: Untriaged → WebRTC
Product: Firefox → Core

Updated

5 years ago
QA Contact: jsmith

Updated

5 years ago
Whiteboard: [WebRTC], [blocking-webrtc-]
(Assignee)

Comment 2

5 years ago
Created attachment 696621 [details] [diff] [review]
fix: change topsrcdir, srcdir and VPATH to absolute path
(Assignee)

Comment 3

5 years ago
this errors are caused by relative $(topsrcdir), $(srcdir) and $(VPATH) in generated Makefile.
To fix, change $(topsrcdir), $(srcdir) and $(VPATH) to absolute path.
(Assignee)

Updated

5 years ago
Attachment #696621 - Flags: review?(ted)
Comment on attachment 696621 [details] [diff] [review]
fix: change topsrcdir, srcdir and VPATH to absolute path

Review of attachment 696621 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py
@@ +370,5 @@
>      else:
>        # Maybe nothing?
>        return False
> +    if self.flavor == 'win' and os.environ.get('.PYMAKE', os.environ.get('_PYMAKE')) != '1':
> +      top = '/' + self.topsrcdir[0:1] + self.topsrcdir[2:]

This is going to break people who build with pymake but don't use client.mk. I think we should just fix bug 828317 so we can only support pymake-style windows paths on windows.
Attachment #696621 - Flags: review?(ted) → review-
Assignee: nobody → h.rayflood
(Assignee)

Comment 5

4 years ago
Created attachment 754119 [details] [diff] [review]
fix v2: always absolute path
Attachment #696621 - Attachment is obsolete: true
Attachment #754119 - Flags: review?(ted)
Comment on attachment 754119 [details] [diff] [review]
fix v2: always absolute path

Review of attachment 754119 [details] [diff] [review]:
-----------------------------------------------------------------

This seems fine now that we stopped supporting GNU make on Windows (bug 828317).
Attachment #754119 - Flags: review?(ted) → review+
Depends on: 828317
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/02d5396a69c5
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/02d5396a69c5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24

Updated

4 years ago
Whiteboard: [WebRTC], [blocking-webrtc-] → [WebRTC], [blocking-webrtc-] [qa-]
You need to log in before you can comment on or make changes to this bug.