OGV Video not seeking - Firefox not sending byte range request

UNCONFIRMED
Unassigned

Status

()

Core
Audio/Video: Playback
UNCONFIRMED
6 years ago
3 years ago

People

(Reporter: Michael Ressler, Unassigned)

Tracking

14 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Running the 14.0.1 Firefox Client I see the following request/response when requesting an OGV video:

 - Request -
GET /StatEasy/videos/00245-2.20120415174030.ogv HTTP/1.1
Host: localhost:8081
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive
Cookie: JSESSIONID=96D2245C8F99C4C826A46C5CC356D664; JSESSIONID=AF91E4B4ABBA219593B305A55306617B

 - Response - 
HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
X-Content-Duration: 570
Etag: W/"280513686-1334526071000"
Last-Modified: Sun, 15 Apr 2012 21:41:11 GMT
Content-Type: video/ogg
Content-Length: 280513686
Date: Fri, 20 Jul 2012 14:43:27 GMT

The symptom I'm seeing that caused me to start looking at the headers:

 - Let the video begin playing on the page
 - Video buffers ahead of playback as expected
 - Attempt to seek beyond the playback buffer

EXPECTED:

 - Seek succeeds in playing at the requested time

ACTUAL:

 - Seek plays from the end of the buffered content

CONTENT:

 - One of the video that I'm seeing this behavior with is posted at http://www.ressq.com/00245-2.20120415174030.ogv
(Reporter)

Comment 1

6 years ago
NOTE: The link I posted will serve the video up from a different server.  While I'm still seeing the same odd initial HTTP request without the byte-range request, the seeking seems to be behaving appropriately.
Component: Audio/Video → Audio/Video: Playback
You need to log in before you can comment on or make changes to this bug.